Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am installing spidermonkey on Ubuntu 11.10. When running ./configure I receive a dependency error that libnotify >= 0.4 is not met.

Located the package in Ubuntu as

gir1.2-notify-0.7

So then I found out where it was installed.

renshaw@renshaw-TravelMate-5740G:~/spidermonkey$ dpkg -L gir1.2-notify-0.7
/.
/usr
/usr/share
/usr/share/doc
/usr/share/doc/gir1.2-notify-0.7
/usr/share/doc/gir1.2-notify-0.7/copyright
/usr/lib
/usr/lib/girepository-1.0
/usr/lib/girepository-1.0/Notify-0.7.typelib
/usr/share/doc/gir1.2-notify-0.7/AUTHORS
/usr/share/doc/gir1.2-notify-0.7/NEWS.gz
/usr/share/doc/gir1.2-notify-0.7/changelog.Debian.gz

So then I have attempted to add this to PKG_CONFIG_PATH with

export PKG_CONFIG_PATH=/usr/lib/:/usr/lib/girepository-1.0/Notify-0.7.typelib

However I still receive the error.

configure: error: Library requirements (libnotify >= 0.4) not met;

How can I get ./configure to see libnotify as gir1.2-notify-0.7?

share|improve this question

1 Answer 1

up vote 3 down vote accepted

You need to install the *-dev packages if you need to compile something using that library.

In your case you need libnotify-dev. Install it and run ./configure again.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.