Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am installing spidermonkey on Ubuntu 11.10. When running ./configure I receive a dependency error that libnotify >= 0.4 is not met.

Located the package in Ubuntu as


So then I found out where it was installed.

renshaw@renshaw-TravelMate-5740G:~/spidermonkey$ dpkg -L gir1.2-notify-0.7

So then I have attempted to add this to PKG_CONFIG_PATH with

export PKG_CONFIG_PATH=/usr/lib/:/usr/lib/girepository-1.0/Notify-0.7.typelib

However I still receive the error.

configure: error: Library requirements (libnotify >= 0.4) not met;

How can I get ./configure to see libnotify as gir1.2-notify-0.7?

share|improve this question
up vote 4 down vote accepted

You need to install the *-dev packages if you need to compile something using that library.

In your case you need libnotify-dev. Install it and run ./configure again.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.