Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Until recently, Firefox on my machine used the standard Unity global menu. However, recently the menu is no longer global and, strangely, is centered. See this screenshot:

screenshot

firefox-globalmenu is installed, the extension is enabled on the Add-ons page, and all other programs work as expected. Furthermore, the menu is as expected in a guest session.

Here are the extensions I have enabled:

  • Adblock Plus 2.0.3
  • AutoPager 0.7.1.2
  • Firebug 1.9.0
  • Flagfox 4.1.11
  • Global Menu Bar Integration 2.0.2
  • InstantFox 2.6.1
  • Searchbar Autosizer 1.5.7
  • Tab Scope 1.1.3
  • Ubuntu Firefox Modifications 1.0.2
  • United States English Spellchecker 5.0.1 (frequently fails to check spelling, allowing words like "spekk" and rejecting all contractions such as "can't")
  • Unity Integration for Firefox 0.2.4

How can I get the global menu back?

(This is Ubuntu Oneiric [11.10] with Firefox 9.0.1.)

Update

I restarted in safe mode (all add-ons disabled). Here's what I saw (note that the only change is that the menubar is no longer centered):

screenshot

Next, I renamed ~/.mozilla to try a fresh profile. The problem was cured. However, I consider this to be an unacceptable solution since I have a lot of settings, add-ons, stored data, etc., etc. that would be lost with a fresh profile, only some of which is covered by Firefox Sync. A solution that involves lost data is no solution.

share|improve this question
    
Is it possible the large number of appindicators are crowding whatever span it needs, making it drop down like that? It sure sounds like you have it set correctly. –  Tom Brossman Jan 27 '12 at 6:52
    
No, in that case, the menu would be displayed instead of the title. –  Jo-Erlend Schinstad Jan 27 '12 at 8:01
    
@TomBrossman: Interesting thought, but as the new screenshot I just uploaded (see edit) shows, there's plenty of room left for the menubar, unless fonts aren't taken into account by the spacing algrithm (I'm using Ubuntu Condensed, as this is a netbook with a small screen). Furthermore, before I changed fonts, I regularly experienced menubars that were longer than the available space. The way Unity handles that is to simply not show the menus on the end (actually, it puts them behing the tray icons and indicators). So unless this was recently changed, it isn't the problem. –  Scott Severance Jan 27 '12 at 8:09
    
@vasa1: D'oh! If I run in safe mode, of course the global menu extension is also enabled. Rather obvious thing for me to overlook, I think. Thanks. If you turn your comment into an answer I'll accept it. My problem was InstantFox, and it's solved. –  Scott Severance Jan 27 '12 at 18:03
add comment

2 Answers

up vote 3 down vote accepted

With your old profile, could you simply disable all extensions and see if the problem goes away? (Somewhat like the safe mode you already tried.) Then, re-enable one extension at a time and see. (Obviously, the global menu bar extension shouldn't be disabled.)

If it's just a single extension (instead of some tricky "synergism"), you may be able to pin-point which one this way and then decide if you can live without it or have to endure the novelty of a centered global menu.

share|improve this answer
    
Thanks. The offending extension was InstantFox. I've disabled it for now and emailed the author. –  Scott Severance Jan 28 '12 at 4:31
add comment

Disable, in the Add-Ons manager, ALL of the following:

  • Adblock Plus 2.0.3
  • AutoPager 0.7.1.2
  • Firebug 1.9.0
  • Flagfox 4.1.11
  • InstantFox 2.6.1
  • Searchbar Autosizer 1.5.7
  • Tab Scope 1.1.3
  • Unity Integration for Firefox 0.2.4

Then re-test, and enable one-at-a-time (or each in turn).

Note: I run Firefox with several add-ons (but none on this list) with NO problems.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.