Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

All right, so, I got a really persistent error. I tried to install mfc6490cwlpr:i386 (downloaded as mfc6490cwlpr-1.1.2-2.i386.deb) and installed it using either gdebi or the Ubuntu Software Centre, probably both even. Following instructions, I restarted my computer and the following error appeared on my upper bar in Unity:

An error occured, please run Package Manager from the right-click menu or apt-get in a terminal to see what is wrong. The error message was: 'Unknown Error:'<type 'exceptions.SystemError'>'(E:The package mfc6490cwlpr:i386 needs to be reinstalled, but I can't find an archive for it.)'. This usually means that your installed packages have unmet dependencies

I tried several ways to remove it. Among the following commands:

sudo dpkg --remove --force-remove-reinstreq mfc6490cwlpr:i386
sudo dpkg --force-all -r mfc6490cwlpr:i386

Digging further into history, I find this command:

sudo dpkg  -i  --force-all  --force-architecture  mfc6490cwlpr-1.1.2-2.i386.deb

I'm running on a 64-bit AMD processor.

Whenever I do anything that involves apt-get, updating, synaptic or what what what, I get this error:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: The package mfc6490cwlpr:i386 needs to be reinstalled, but I can't find an archive for it.

The updater recommended a dist-upgrade, which didn't work.

Does anyone have any ideas to remove the corrupt .deb? I can reinstall it later when I have more time to look into hooking up the printer. But for now, I'm more concerned about getting it off off my computer.

Worth mentioning: I am NOT adept at the command line, though I try hard. I'm fairly dangerous with it, actually.

share|improve this question
I was going to post that just now, thank you for referencing my blog. – bodhi.zazen Jan 26 '12 at 22:17
Thanks man :) That blog post really helped me. – Ruben Bakker Jan 26 '12 at 23:37
up vote 2 down vote accepted

(posted in question by OP)


Fixed it already. The following link helped:

Here's what it says: Go into the /var/lib/dpkg/info directory using the terminal. Do:


Mind that the asterisk (*) is important. If all's right you get five results, of which 3 are green. At least, that was the case in my case. If you get more, write the name of the package almost in full and try the above command again.

Then do:


And follow with:

sudo dpkg --remove --force-remove-reinstreq [NAME OF PACKAGE]

Don't follow this advice if you haven't tried anything else yet. I fear it's highly destructive, lol, but I survived the aftermath and apt-get is working again.

share|improve this answer

The following is a graphical and clean method.

Open the Update Manager app, check for updates. You should see "Partial upgrade" appearing. Click on it and verify it proposes to remove your particular package only. Then proceed.

share|improve this answer
I tried that before my own fix. It worked well at first, but eventually cut off somewhere during the process. When I tried it again later, it wouldn't start up anymore. It seemed to work for others, though, but not in my case. – Ruben Bakker Jan 26 '12 at 23:37

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.