Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

After installing Slitaz today I wanted to create a dualboot with Lubuntu I had installed before. Somehow the Grub doesn't load Lubuntu (error 15). I've added a screenshot of the current menu.lst

Can anyone help me with this? I just wanted to test Slitaz, but now I seem to have lost all access to my Ubuntu!!

Screenshot of menu.lst

share|improve this question

1 Answer 1

Slitaz installed grub 1 (legacy) and it looks as if it did not add in the Ubuntu initrd.

At that screen, hit e to edit the ubuntu stanza , and add a line

initrd /boot/initrd.img-2.6.30.6-generic

After booting ubuntu, reinstall grub

sudo grub-install /dev/sda

It should recognize slitaz as well.

share|improve this answer
    
Thanks for answering, but this doesn't work either. I added the line in the GRUB by pressing 'e'. Still error 15 occurs... –  Tim Jan 26 '12 at 19:31
    
You have the wrong root then. Boot a live CD and determine which partition is Ubuntu . root (hd0,0) or root (hd0,1). You can also follow this link for how to recover help.ubuntu.com/community/… –  bodhi.zazen Jan 26 '12 at 19:36
    
oh wait...I now get error 17 (cannot mount selected partition). I get this because I added your line and changed hd0,22 to hd0,1 in the menu.lst. Am I getting closer? –  Tim Jan 26 '12 at 19:58
    
Doing it right now –  Tim Jan 26 '12 at 20:38
    
I couldn't get it right, so I just reinstalled Ubuntu completely. I will not try slitaz again for some time... –  Tim Jan 27 '12 at 10:02

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.