Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I want download ghc6. But, when I type

   sudo apt-get install ghc6 
   sudo apt-get -f install ghc6
   sudo apt-get install --reinstal ghc6

it gives same error:

 Reading package lists... Done
 Building dependency tree       
 Reading state information... Done
 Some packages could not be installed. This may mean that you have
 requested an impossible situation or if you are using the unstable
 distribution that some required packages have not yet been created
 or been moved out of Incoming.
 The following information may help to resolve the situation:

 The following packages have unmet dependencies:
   ghc6: Depends: libgmp3-dev but it is not installable
         Depends: libffi-dev but it is not installable
         Depends: libbsd-dev but it is not installable
 E: Broken packages

How can I fix that OR How can I install ghc6 to my desktop

ubuntu 10.04

EDIT :

apt-cache policy ghc6 libgmp3-dev; apt-cache show ghc6 libgmp3-dev


ghc6:

 Installed: (none)

 Candidate: 6.12.1-12

Version table:
 6.12.1-12 0
    500 http://archive.ubuntu.com/ubuntu/ lucid/universe Packages

libgmp3-dev:  
Installed: (none)  
Candidate: (none)
Version table:
Package: ghc6
Priority: optional
Section: universe/devel
Installed-Size: 378532
Maintainer: Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Original-Maintainer: Kari Pahula <kaol@debian.org>
Architecture: amd64
Version: 6.12.1-12
Replaces: ghc6-doc (= 6.12.1-8), haddock
...    
Conflicts: ghc4 (<= 4.08.1-4), haddock
Breaks: cabal-install (<< 0.8.0), ghc6-doc (<= 6.12.1-8), haskell-devscripts (<<     0.6.19)
Filename: pool/universe/g/ghc6/ghc6_6.12.1-12_amd64.deb
...
Description: GHC - the Glasgow Haskell Compilation system
...
additional documentation can be found in the `haskell-doc' package.
 Alternatively, there is an online version at
 http://haskell.org/onlinereport/.
Homepage: http://haskell.org/ghc/
Bugs: https://bugs.launchpad.net/ubuntu/+filebug
Origin: Ubuntu


sudo apt-get install libgmp3-dev libffi-dev libbsd-dev
E: Could not get lock /var/lib/dpkg/lock - open (11: Resource temporarily unavailable)
E: Unable to lock the administration directory (/var/lib/dpkg/), is another process using it?
share|improve this question
1  
1. Check if the ghc6 and libgmp3-dev come from the ubuntu official repositories and not a third party repository: apt-cache policy ghc6 libgmp3-dev; apt-cache show ghc6 libgmp3-dev 2. Check why the 3 packages are not installable by installing them: sudo apt-get install libgmp3-dev libffi-dev libbsd-dev –  medigeek Jan 26 '12 at 10:54

1 Answer 1

up vote 1 down vote accepted

install the dependencies listed here, then you can build from source.

or try this

Update the package index: sudo apt-get update Install ghc6-prof deb package: sudo apt-get install ghc6-prof

try this link

share|improve this answer
    
for sudo apt-get install haskell-platform error : sudo apt-get install haskell-platform E: Could not get lock /var/lib/dpkg/lock - open (11: Resource temporarily unavailable) E: Unable to lock the administration directory (/var/lib/dpkg/), is another process using it? –  user8324 Jan 26 '12 at 11:02
    
for website, not found –  user8324 Jan 26 '12 at 11:03
    
sudo apt-get install ghc6-prof E: Could not get lock /var/lib/dpkg/lock - open (11: Resource temporarily unavailable) E: Unable to lock the administration directory (/var/lib/dpkg/), is another process using it? –  user8324 Jan 26 '12 at 11:03
    
sorry for broken link now it will work , and some where u r using your dpkg . kill all dpkg try killall -w aptget –  Gaurav_Java Jan 26 '12 at 11:06
1  
or if that doesn't work try this sudo dpkg --configure -a after that follow my answer –  Gaurav_Java Jan 26 '12 at 11:09

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.