Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I opened the introduction in LyX and used Ctrl+R to view it in evince. The fonts appear nice and smooth. If I copy and paste the first couple of paragraphs into a new document and render that, the fonts have jagged, pixellated edges (especially visible upon zooming).

This is with no customisation to LyX at all — a fresh installation via Synaptic. I can't see any differences between the document settings for the new documents (although there are probably some differences due to autodetection).

How can I make the fonts look smooth in my own documents? Particularly of the article class and beamer presentations?

Jagged fonts from my own document Smooth fonts from the introduction

share|improve this question

3 Answers 3

up vote 3 down vote accepted

To solve the same problem I resorted to install the package cm-super.

Maybe it could be preferable, because you don't need to always remember to put those lines in the preamble.

share|improve this answer
    
Nice! I agree, it is preferable. –  detly Jan 26 '12 at 12:25

By default the fonts in LyX are bitmap (very long story, don't ask). To avoid this you simply need to select a different set of fonts in Doc > Settings > Fonts. The Latin Modern family should give the same look and feel as CM, only using vector fonts. I like Palatino with Optima (see this rant), but feel free to choose what works best for you.

The LyX FAQ might have some information that you can use.

share|improve this answer

Insert this into the LaTeX preamble (there's a section for that in the document settings):

% set fonts for nicer pdf view
\IfFileExists{lmodern.sty}{\usepackage{lmodern}}{}
share|improve this answer
    
I feel like an idiot: seconds after posting this question, I realised I hadn't checked the preamble in the introduction. There is was, plain as anything: set fonts for nicer pdf view. Duh. But here's the answer, to save others the time. –  detly Jan 26 '12 at 9:30
1  
strange that this isn't the default setting. I can't imagine a use case where someone wants ugly fonts. –  waspinator Dec 11 '12 at 17:39

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.