Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have ubuntu 11.10.

In my grub menu, I have following images:

linux 3.*

linux 2.*

linux 2.*

My linux 3.* image is broken (if I try to boot from first image, i.e. linux 3.*, I get my caps and scroll lights blinking, and nothing appears on my screen).

If I boot from my second image, everything works just fine. My update manager shows everything updated. My software sources are updated. How do I fix my grub loader.

Thanks.

share|improve this question

2 Answers 2

It sounds as if grub is working just fine (you can boot an older kernel) but that you are having a problem with the new kernel (rather then grub).

For this I would file a bug report against the new kernel, but you will need to provide the error message you are getting.

See - https://wiki.ubuntu.com/Kernel/Bugs

share|improve this answer
    
There is no error message I am getting...I just boot into it and nothing happens...even the recovery mode. –  hrishikeshp19 Jan 26 '12 at 19:49

The problem can be in one of two places, the loader or the Linux kernel. Although, it's seems to be more likely to be a kernel problem, I seem to have solved the problem with the following:

sudo update grub

Or else, something to the order of the following (taken from Can no longer boot with rEFIt and Grub on early 2006 MacBook Pro) might help:

/usr/sbin/grub-install --force /dev/sda3

And there's always the grub manual.

The best,

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.