Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I did read the several posts available here on "changing ownership of read-only file systems" but they don't seem to help me.

My external hard drive (which I had previously formatted in OS X and used on it for over a year) doesn't allow me to copy anything from/on to it FROM my Ubuntu 11.10

It says that the file system is read only when I try this:

sudo chown -R my-user-name /"Untitled 1"

Where "Untitled 1" is the name of the external hdd.

Any suggestions?

Even getting into nautilius with sudo nautilius to change the ownership didn't work.

(on a side note, what is nautilius anyway? I know I can google THAT)

What should I do now?

share|improve this question
1  
Nautilus is the default file manager in Ubuntu. –  Amanda Jan 25 '12 at 20:33

3 Answers 3

Remount the partition (or disc) but this time with rw (read, write) settings. Should be something like this:

sudo mount -o rw,remount /"Untitled 1"

share|improve this answer
    
All that in the same line? I am a completely new person to Ubuntu. Because ubuntu says that there is no command such as remount. –  drN Jan 25 '12 at 20:43
    
You could also try typing: sudo umount /"Untitled 1" pressing enter then typing sudo mount -o rw /"Untitled 1" and pressing enter which should have the same affect described here. –  Mykroft Jan 25 '12 at 20:50
    
@Mykroft I tried what you said but my terminal said mount: can't find Untitled 1 in /etc/fstab or /etc/mtab :( This is ridiculous! I am beginning to hate ubuntu. –  drN Jan 25 '12 at 20:53
    
And when you typed the above command all on one line it said no such command as remount? –  Mykroft Jan 25 '12 at 20:56
    
DNA so add the disc to your /etc/fstab. Remember: Linux/Ubuntu is NOT difficult. It's only different. You learn and it becomes normal to you. –  Rinzwind Jan 25 '12 at 21:15

Usually the cause of the fs being mounted read only is because there are errors. You can run dmesg in a terminal and see if there are any errors reported, and you should check the filesystem with the disk utility.

share|improve this answer
up vote 1 down vote accepted

Ok, so after a lot of looking around and conferring with my friends, this is what worked for me.

My external hard drive has a journaled file system (hfs+). I don't quite care what that means but I had to "disable journaling".

For this I had to connect my hdd to my macbook and run the following command in it's terminal

sudo /usr/sbin/diskutil disableJournal /Volumes/name-of-my-external-hdd

That worked and my hdd is now read AND write enabled!!

Hope this helps someone in the future! :)

share|improve this answer
1  
It works, but this fix is not recommended. Check this askubuntu.com/questions/16811/… –  mac Aug 13 '12 at 12:34
    
@mac Thanks! :) –  drN Aug 14 '12 at 17:38

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.