Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I recently upgraded from 10.04 LTS to 11.10. I use this machine remotely via NoMachine during the day and had some issues with Unity so I switched the desktop to Gnome while at home last evening. It worked fine, but when I'm using NoMachine the applications menu is missing from the top toolbar.

I would like to switch it back to Unity, but it logs directly into the desktop without being able to set the desktop option.

I'm guessing the desktop setting is contained in a file and I can edit it via ssh shell and Vim, but have no clue where the file is or what it's called.

Any suggestions?

share|improve this question
    
Please have a look at Why do I get Unity instead of Classic when using NX?, let us know if that can help you solve your issue. –  Bruno Pereira Jan 25 '12 at 16:25

2 Answers 2

up vote 5 down vote accepted

Add a custom command to your Nomachine NXClient, which says gnome-session --session=ubuntu-2d. That will launch Unity 2D which uses Metacity instead of Compiz. NX is not capable of using Compiz (Unity) or Mutter (Gnome Shell). Unity 2D with Metacity works nicely though.

share|improve this answer
    
Thanks for the response! I tried it, but NoMachine is opening multiple windows (that can't be opened themselves), then the connection to the remote Ubuntu machine is closed. I've tried all teh available options in the NoMachine UNIX custom session dialog box, but no luck. When I switched back to the old Gnome desktop another tutorial said to install the gnome-shell package. In case that was causing the problem I removed it and re-started, but get the same response. –  jacoulter Jan 25 '12 at 16:01
    
That is strange. I have actually tested this, and it has worked on all versions I've tried, including OpenNX, Nomachine NX Client and X2go client. I don't know what's causing this. In any case, however, I would recommend that you give X2go a try. It's much better integrated with Ubuntu. It's an NX product, but not compatible with Nomachine. –  Jo-Erlend Schinstad Jan 25 '12 at 16:43
    
x2go using the custom desktop command gnome-session --session=ubuntu-2d did the trick - thanks for your time and help! –  jacoulter Jan 25 '12 at 19:36
    
Great! Thanks for the solution! (On my machine, I think I also had to select the radiobutton for "New virtual desktop" to get it to work right, but your mileage may vary.) –  D.W. Jul 18 '12 at 1:00

This link explains what the problem is and how to get NX Client to work with Ubuntu 11.10. The instructions there worked for me.

http://www.nomachine.com/tr/view.php?id=TR10I02623

Excerpt for your convenience:

The system menu may be missing in a NX session running on Ubuntu 11.10 if the desktop environment is Unity 3D

The system menu is missing inside the NX session when the Unity 3D desktop environment is launched instead of Unity 2D.

Unity 2D is the fallback for those X servers not supporting 3D graphics as it is for the X11 agent, nxagent. However, if the hosting machine has support for a 3D graphic card, Unity 3D is launched also inside the NX session.

Ubuntu 11.10 comes with a script, the Unity Support Test, to verify if the hosting computer supports or not Unity 3D. If yes, a file is stored in the /tmp directory.

In order to override this behavior and run Unity 2D instead of Unity 3D, it is necessary to delete the file created by the Unity Support Test tool inside the /tmp directory. This file has format /tmp/unity_support_test.X where X is a progressive number, for example:

/tmp/unity_support_test.1

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.