Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I need to run an applet that requires java 1.5.

It does not matter if I should uninstall java 6. Even doesn't matter if it applies for firefox or chrome.

I am using Ubuntu 10.04

share|improve this question
up vote 4 down vote accepted

You don't need to downgrade your Java. Java 6 can run Java 5 (or 1.5) applet. You just need to install the plug-in for your browser.

It depends on which flavour of Java you're using:

  • if using openjdk, install icedtea6-plugin
  • if using sun-java6, install sun-java6-plugin

Both packages are installable via Synaptics or the command line using apt-get.

If you're using the Ubuntu Software Centre look for respectively:

  • Icedtea Java Plugin
  • Sun Java 6.0 Plugin
share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.