Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Before I upgraded to 10.04 last spring, I remember having a timer counting down from 60 after clicking the shutdown button. This gave me a 60 second time frame to interrupt the shutdown in case I forgot to do something.

Since the upgrade this is gone and my system shuts down immediately when I click the button. Anyone who knows how to re-enable the timer?

share|improve this question
add comment

2 Answers

The timer is no longer an option. The rationale for the removal:

Yes, this is by design. Basically, if the dialogs come up fast enough it doesn't really make a whole lot of sense to have them count down as well. People will see and respond to them. Thanks for noticing.

Source: https://bugs.launchpad.net/ubuntu/+source/indicator-session/+bug/548415

share|improve this answer
    
So basically the developers decided to just remove a functionality instead of adding the possibility to disable it with setup? That doesn't sound very logical. Does it? I think the scenario I described above is a good reason to keep that functionality available. –  W. Goeman Oct 28 '10 at 19:00
    
@KingWilliam I agree and so do a lot of other people. –  Alvin Row Oct 28 '10 at 19:05
add comment

You can't re-enable the timer, but you can have a shutdown confirmation dialog.

This is configured with the /apps/indicator-session/suppress_logout_restart_shutdown key in GConf.

You can start GConf Editor by launching the Run dialog (Alt+F2) and typing gconf-editor and then executing it.

share|improve this answer
    
I already have the confirmation dialog ;) –  W. Goeman Oct 28 '10 at 19:02
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.