I was trying to upgrade my system from 10.10 to 11.04.
The following packages have unmet dependencies: plymouth : Depends: libdrm-nouveau1a (>= 2.4.23) but it is not installed Depends: libplymouth2 (= 0.8.2-2ubuntu22) but 0.8.2-2ubuntu5.1 is installed plymouth-label : Depends: libplymouth2 (= 0.8.2-2ubuntu23) but 0.8.2-2ubuntu5.1 is installed Depends: plymouth (= 0.8.2-2ubuntu23) but 0.8.2-2ubuntu22 is installed plymouth-x11 : Depends: plymouth (= 0.8.2-2ubuntu5.1) but 0.8.2-2ubuntu22 is installed E: Unmet dependencies. Try using -f.
When i do apt-get -f install, I get the same errors alongwith two more lines:
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages. E: Unable to correct dependencies
Now, I am unable to install, remove or upgrade or do anything. How do I solve this, atleast how do i force enable my system to install, remove stuff.
MORE: I have also tried dpkg configure and also tried to purge remove plymouth for starters. But nothing works.
Update: Also, I have tried removing all the ppas which included xorg-edgers which probably has caused some issues. But not having/having that ppa in sources.list.d changes nothing.