Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a Samsung R780 laptop with Synaptics touchpad that's been working fine since I installed 11.10 back in October. Now it's stopped working, this suddenly happened today but I haven't had an update since a couple of days ago so no idea what triggered it. Symptoms are the touchpad works fine at the login screen, but as soon as I login and the desktop appears it stops working. A USB mouse works OK I've tracked it down (I think) to gnome-settings-daemon. I have turned off "disable-while-typing" using

gsettings set org.gnome.settings-daemon.peripherals.touchpad disable-while-typing false

If I run

xinput watch-props "SynPS/2 Synaptics TouchPad"

in one terminal, and then run

xinput set-prop "SynPS/2 Synaptics TouchPad" "Device Enabled" 1

in another terminal, the touchpad is enabled for a few seconds, and then something else disables it again, here's the messages from xinput watch-props:

Property 'Device Enabled' changed.
    Device Enabled (143):   1
Property 'Synaptics Tap Action' changed.
    Synaptics Tap Action (303): 0, 0, 0, 0, 0, 0, 0
Property 'Synaptics Edge Scrolling' changed.
    Synaptics Edge Scrolling (294): 0, 0, 0
Property 'Synaptics Two-Finger Scrolling' changed.
    Synaptics Two-Finger Scrolling (295):   0, 0
Property 'Synaptics Edge Scrolling' changed.
    Synaptics Edge Scrolling (294): 0, 0, 0
Property 'Synaptics Two-Finger Scrolling' changed.
    Synaptics Two-Finger Scrolling (295):   0, 0
Property 'Device Enabled' changed.
    Device Enabled (143):   0

so something (I believe gnome-daemon-settings) keeps disabling it. If I'm quick I can move the mouse for a couple of seconds after enabling it so I'm sure this is the problem.

Also, if I switch to a virtual terminal (Ctrl+Alt+F1) and back to X again the touchpad is enabled for a couple of seconds before it gets disabled again.

I can't see any settings in gconf-editor that would cause this, also I have no idea why it suddenly started happening. This behaviour happens consistently between reboots now. It's the same whether I run Unity or Gnome shell so not specific to any window manager.

Am I doing something stupid, or should I file a bug report?

share|improve this question
1  
Not sure where I should be asking this - but I don't think this should have been closed. As it says at the top, Possible duplicate. That question related to the touchpad not working in 11.10 from the start, mine stopped working after being fine for months. And I've already tried installing the sergio91pt driver but it makes no difference. None of the other similar questions have described the same symptoms. So -- any ideas? Apart from killing off gnome-daemon-settings I can't see how to fix it. –  Dave Strawbridge Feb 10 '12 at 19:24
    
This question appears to be abandoned, if you are experiencing a similar issue please ask a new question with details pertaining to your problem. If you feel this question is not abandoned, please flag the question explaining that. :) –  Ringtail Dec 31 '12 at 2:11

2 Answers 2

Try this:

xinput set-prop "SynPS/2 Synaptics TouchPad" "Synaptics Off" 0
share|improve this answer
1  
Unfortunately that property was already set to zero, so this doesn't fix the problem. Thanks anyway –  Dave Strawbridge Feb 10 '12 at 10:37

I have experienced the same behavior as the original poster of this question (on a different laptop) under gnome-session 3.2.1. Another symptom was that after going back to the display manager/login screen (that is after logging out or switching the user), the touchpad started working again.

The following helped me:

gsettings set org.gnome.settings-daemon.peripherals.touchpad touchpad-enabled true
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.