Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

In Kubuntu (both Precise and Oneiric) the font rendering is really different from Gnome. The ubuntu font is not well displayed because it is always used the bold one instead of 'regular' resulting in a fat interface.

Is there a way to fix this?enter image description here

share|improve this question
add comment

2 Answers

Go to Fonts – KDE Control Module.

Set Use anti-aliasing to Enabled, then press Configure... and try different Hinting style settings.
I use Medium.

Screenshot

share|improve this answer
    
I played with font settings in kde control module but also switching to slight or medium the situation doesn't improve. Using the medium setting the fonts are no more bold but look weird (like in your screenshot), using instead slight (how it should be in GNOME) fonts looks bold. I believe this is related to this bug report: bugs.launchpad.net/ubuntu-font-family/+bug/744812 (it is marked as solved but it is still present!) –  lucazade Jan 25 '12 at 9:41
add comment

This is because of the Ubuntu font, which has not just Bold and Regular, but Bold, Medium and Light styles.

On your screenshot the font is bold because it's Medium style. Go to System Settings -> Application Appearance -> Fonts and select Light style:

enter image description here

Another solution - use another font. I insist you to try Droid fonts. For this install ttf-droid package.

share|improve this answer
    
wrong.. font is bold because qt4 is not able to use Regular weight and it uses Medium. In kde settings I've used Regular weight but unfortunately this upstream bug makes fonts bold. Droid or other fonts are not a solution.. I want to use default stuff. –  lucazade Jan 27 '12 at 7:12
    
what precisely is wrong? i said the same thing - that kde is using Ubuntu Medium. I just didn't know the reason, which turned out to be a bug. –  warwaruk Jan 27 '12 at 12:32
    
btw, i think in kde 4.8 it's solved –  warwaruk Jan 27 '12 at 12:35
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.