Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Setup in Ubuntu 11.10 installation gives me this message while in advanced partitioning:

"The file system type fat32 cannot be mounted on /home, because it is not a fully-functional Unix file system. Please choose a different file system, such as ext2."

Is there a way to force the use of the fat32 partition so I can share it with Windows, but also using it as home?

share|improve this question
up vote 0 down vote accepted

A slight improvement over the "shared ntfs data partition" recipe suggested by @bodhi.zazen is to set up /home on an ext partition, mount an NTFS partition at, say, /mount/disk and then replace directories the user's home folder with symlinks to directories on the NTFS partition.

  • /home/username/Documents -> /mnt/disk/my_linux_data/Documents
  • /home/username/Music -> /mnt/disk/my_linux_data/Music

etc. Then, if you make a point not to save files in your home folder directly, the process will be totally transparent.

share|improve this answer
    
okay, this way looks pretty much what i need but, is there a way to not make a separate partition for /home this way? – crackout12 Jan 25 '12 at 5:31
    
Sure, you can just keep it on your root partition - it will be just a directory – Sergey Jan 25 '12 at 5:35
    
Don't do it. It will lead to nothing but trouble. The files will show up on linux as executable, since there is no executable flag on fat filesystems, but you need them, to step into a directory. Sharing text files with Windows CR+LF lineendings is another annoyance. – user unknown Jan 25 '12 at 10:16
    
@user unknown: thank you for downvoting :) Executable flag on files is a matter of mounting options - you can have files without executable bit and directories with one. CR/LF problem is not solved by any other method of sharing files - is your solution "do not share data between Windows and Linux at all"? Also, plain text files used quite rarely these days anyway, especially on Windows. – Sergey Jan 25 '12 at 10:45

No. The problem is that vfat does not support permissions so you can not use it as home.

You are almost certainly better off using a shared ntfs data partition.

Alternately you can install the fs-driver in windows

http://www.fs-driver.org/

It will read ext2/3/4 and you are going to be better off using ext4 for /home.

share|improve this answer
    
Thanks for your answer! – crackout12 Jan 25 '12 at 5:25

Obviously no because system can't manage user permissions on FAT32 but... BUT WHAT IF WE MOUNT FAT32 AS /home/THEUSER AND MAKE THE WHOLE FAT32 SYSTEM BELONG TO "THEUSER"??? O_o

o_O O_O O_o X_X -_- X_X -_- o_o

share|improve this answer
    
Hmmm... besides your weird faces, (:p) I guess you have a point. If I'm making this partition as a home (~) folder for a user, why would any other user need to have access to it, besides root, which in the way you proposed, would already have it anyway. I mean, it's the home folder! If there's a folder in the system only a specific user should have access to, this is the place! – Bruno Finger Dec 3 '15 at 9:22
    
Will not work as not every file in $HOME is owned by the user and not every file/directory has the same permissions. .ssh or .gpg for example to name a few. – bodhi.zazen Jun 13 at 17:49

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.