Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Possible Duplicate:
Ubuntu Server 11.10 boot, white terminal with garbled black text

I need to add a parameter to the grub entry for ubuntu.

console=ttyl

how do i set this? I know how to do it manually for each boot but how do i set it to be automatically passed as a param?

I am using GRUB 2 and Ubuntu 11.10

Thanks, Speed

share|improve this question
    
I answered in your other question askubuntu.com/questions/98294/… , sorry for the confusion –  bodhi.zazen Jan 25 '12 at 3:32
add comment

marked as duplicate by Marco Ceppi Jan 25 '12 at 23:34

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

1 Answer

If you want this parameter to be permanently added to your default linux boot parameters you should modify the GRUB configuration file.
Edit your “/etc/default/grub” and modify the appropriate line to be something like GRUB_CMDLINE_LINUX_DEFAULT="quiet splash console=ttyl".
Save the file and run update-grub so that changes will take affect.

share|improve this answer
    
That screwed my boot up. Itplaced the param in a line begining with linux\ ....... and would not boot. –  SpeedCrazy Jan 25 '12 at 15:46
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.