Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have instlaled MySQL Administrator and it works fine, except one annoying thing. Every time i select a table and click 'Edit Table Data' from context menu, it prompts for password.

Any idea how to fix this?

share|improve this question
    
An Alternative Way Is To Create An Alias example > alias cmsql='mysql -u root -p1' < So When Ever You Type cmsql (Connect MySQL ) It Will Connect To MySQL Without Password Cauzz Its Defined In An Alias , Where As My Password Is "1" –  One Zero Mar 28 '12 at 5:38
add comment

2 Answers

I haven't used this particular tool, but I'll take a guess that it reads from ~/.my.cnf like most utilities that talk to MySQL do.

Try creating a file in your home directory, named .my.cnf, with the following:

[client]
user = USERNAME
password = PASSWORD

Replace USERNAME and PASSWORD accordingly and give it another shot.

To check it's working, you should then be able to run the mysql client program from the terminal and it should log right in with no prompt.

share|improve this answer
    
But I connect to many servers, and have separate credentials for each. Also, storing a password in plain text under home dir is not very secure. However, I find that there is Tools > Preferences > General Options > Store connection passwords which will save encrypted password and prevent from retyping password every time, but it still pops up every time you click ` 'Edit Table Data` and you need to confirm. –  umpirsky Jan 31 '12 at 8:35
add comment

Are you logging in from root account ? create a root account by using MYSQL Administrator with debian-sys-maint account whose username and password are present in /etc/mysql/debian.cnf

see if it helps

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.