Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am trying to configure my remote. The good news, is that it "Just worked". Meaning: I plugged it in, ran the gnome-lirc-properties and now I can control some parts of my desktop with it.

It seems, though, that it is not lirc handling it. I have killed lircd. It does not show under ps:

ps faux | grep ir
#shows a few processes, like firefox, but nothing like lirc(d), irw, irrecord etc.

The device is still active thought:

sudo cat /dev/lirc0

Pressing buttons on my remote make it print all sorts of strings.

Pressing buttons on my remote actually control Gnome/Unity/Desktop. E.g. Volume up and down make the volume go up and down, mute works, the "windows-button" fires up banshee and so on.

What is reading out my remote? And how can I configure that?

share|improve this question

3 Answers 3

up vote 2 down vote accepted

Like Florian said, Ubuntu is seeing the remote as a keyboard.

You can add the below to /etc/X11/xorg.conf to stop X from picking it up:

Section "InputClass"
  Identifier "Remote"
  MatchProduct "<your transceiver input name>"
  Options "Ignored" "True"
EndSection

(If there is no xorg.conf, just create it (sudo gedit /etc/X11/xorg.conf))

To get your input name:

cat /proc/bus/input | grep Name

(Just pick the one that seems closest to what you think it is, mine is "Media Center Ed. eHome Infrared Remote Transceiver")

Then install lirc (sudo apt-get install lirc) and go through the setup process (I have to run sudo dpkg-reconfigure lirc to get the setup dialog to run for some odd reason)

Then reboot (or run sudo restart lightdm and log back in)

share|improve this answer

Quite likely your remote is used as a keyboard. I don't know any real useful docs for how to configure it but /lib/udev/rules.d/95-keymap.rules and the files in /lib/udev/keymaps/ may give you some idea about how to do it.

share|improve this answer

This is the correct version of the Option line:

Option "Ignore" "True"
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.