Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just installed ubuntu on my computer after that I instaled the recommended driver for Nvidia GeForce FX 5600XT and display resolution is 640x320 how can I change it to a higher resolution , I really would appreciate if somebody could help me ,thanks

share|improve this question

1 Answer 1

I followed these instructions to add 1680x1050 to my settings. It was pretty simple to follow: Open the Terminal with Ctrl-Alt-T and type: xrandr Which will output something similar to this:

Screen 0: minimum 320 x 200, current 1024 x 768, maximum 4096 x 4096
VGA-0 connected 1024x768+0+0 (normal left inverted right x axis y axis) 0mm x 0mm
   1360x768       59.8  
   1024x768       60.0* 
   800x600        60.3     56.2  
   848x480        60.0  
   640x480        59.9     59.9  
DVI-0 disconnected (normal left inverted right x axis y axis)
S-video disconnected (normal left inverted right x ax

Next you'll add your monitor's resolution. For this example it's 1680x1050 so you would type this next in the terminal: cvt 1680 1050 and press return.

You will use the output of the the step above for the next step. Now past this (change to reflect your actual settings:

1

xrandr --newmode "1680x1050_60.00" 146.25 1680 1784 1960 2240 1050 1053 1059 1089 -hsync +vsync

Next type:

2

xrandr --addmode VGA-0 1680x1050_60.00

be sure to replace the numbers with your own. This is where I had to change it a little from the tutorial I'll link to which goes into more detail. I had to change VGA-0 to VGA1 for it to work for me.

Now you tell the server to display the new size:

3

xrandr --output VGA-0 --mode 1680x1050

To have the code appear in the Monitor settings panel you'll have to edit the gdm defaults by typing:

sudo gedit /etc/gdm/Init/Default The settings will appear using the gedit code editor. 

Find these lines in the file:

PATH="/usr/bin:$PATH"

OLD_IFS=$IFS

You'll add the three xrandr commands you've just entered which I've numbered in bold text above after those lines and save the file.

It worked for me. Here is the link to the much more detailed and original post:

The Perpetual Newbie

share|improve this answer
    
I tried this but there was no file found at /etc/gdm/Init/Default. In fact etc/gdm doesn't even exist –  hellocatfood Apr 8 '12 at 1:20
    
gdm is the default display manager but perhaps it's not installed. You probably have LightDM only, I'd guess. –  Jeremy Jared Apr 8 '12 at 3:59

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.