Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I did a fresh install of Ubuntu 11.10 on my DELL Vostro 1500. I found out I need to have the hardware wireless switch off in order to boot, otherwise it will hang midway during the booting process. Once logged in, if I turn the hardware switch on, network-manager will change to "device is not ready" (in the wireless section), and Ubuntu will freeze after I press a few keys on my keyboard.

As you can see, I have 2 network cards. The BCM4401-B0 (wired) works, but the Intel Wireless 3945 ABG is giving me a hard time.

$ lspci -nnk | grep -iA2 net
 03:00.0 Ethernet controller [0200]: Broadcom Corporation BCM4401-B0 100Base-TX [14e4:170c] (rev 02)
 Subsystem: Dell Device [1028:0228]
 Kernel driver in use: b44
 --
 0c:00.0 Network controller [0280]: Intel Corporation PRO/Wireless 3945ABG [Golan] Network Connection [8086:4222] (rev 02)
 Subsystem: Intel Corporation Device [8086:1020]
 Kernel driver in use: iwl3945

Here is some hardware info (before switching the hardware switch on):

$ sudo lshw -C network
 *-network DISABLED     
   description: Wireless interface
   product: PRO/Wireless 3945ABG [Golan] Network Connection
   vendor: Intel Corporation
   physical id: 0
   bus info: pci@0000:0c:00.0
   logical name: wlan0
   version: 02
   serial: 00:1c:bf:8b:55:a5
   width: 32 bits
   clock: 33MHz
   capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
   configuration: broadcast=yes driver=iwl3945 driverversion=3.0.0-15-generic firmware=N/A latency=0 link=no multicast=yes wireless=IEEE 802.11abg
   resources: irq:44 memory:f9fff000-f9ffffff
 *-network
   description: Ethernet interface
   product: BCM4401-B0 100Base-TX
   vendor: Broadcom Corporation
   physical id: 0
   bus info: pci@0000:03:00.0
   logical name: eth0
   version: 02
   serial: 00:1d:09:b6:1a:de
   size: 100Mbit/s
   capacity: 100Mbit/s
   width: 32 bits
   clock: 33MHz
   capabilities: pm bus_master cap_list ethernet physical mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
   configuration: autonegotiation=on broadcast=yes driver=b44 driverversion=2.0 duplex=full ip=192.168.0.106 latency=64 link=yes multicast=yes port=twisted pair speed=100Mbit/s
   resources: irq:17 memory:f9bfe000-f9bfffff

And here are the modules loaded:

$ lsmod | grep -i iwl
 iwl3945                83430  0
 iwl_legacy             83487  1 iwl3945
 mac80211              462092  2 iwl3945,iwl_legacy
 cfg80211              199630  3 iwl3945,iwl_legacy,mac80211


$ lsmod | grep -i b4
 b44                    36315  0
 ssb                    52752  1 b44

In order to diagnose, I did a less /var/log/syslog and hit SHIFT-F to see the stuff coming in in real time. Here is what I see right after switching the hardware switch on (I tried it a couple of times, so I am sure all this is triggered by me switching the hardware wireless switch on):

[kernel] kbd_keycode: 30 callbacks suppressed
[kernel] keyboard: can't emulate rawmode for keycode 240
[kernel] keyboard: can't emulate rawmode for keycode 240
[NetworkManager[910]]: <info> WiFi now enabled by radio killswitch
[NetworkManager[910]]: <info> (wlan0): bringing up device
[kernel] iwl3945 0000:0c:00.0: loaded firmware version 15.32.2.9
[kernel] iwl3945 0000:0c:00.0: wait for START_ALIVE timeout after 2000ms

Any help will be appreciated.

share|improve this question

closed as off topic by Marco Ceppi Feb 4 '12 at 21:05

Questions on Ask Ubuntu are expected to relate to Ubuntu within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

    
This question should instead be filed as a bug report, thanks! Instructions here. –  Jorge Castro Feb 4 '12 at 20:01