Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a problem with my Laptop (Dell Inspiron 1564 Core i5 4GB Ram VGA ATI Mobility Radeon HD 4300 running Ubuntu 10.10 32bit). It shuts down abruptly without even a lag in the application I am working with before shutdown. I think it's overheating problem. Actually the laptop is hot all the time when I am running Ubuntu. When I switch back to windows, even with intense load it won't shutdown or show any problem as long as I keep proper ventilation (when the air openings are blocked it does the same).

Actually on Ubuntu i don't usually do things that need much CPU power, usually surfing internet, coding web pages and sometimes playing with python and ruby. I am not enabling desktop effects so no GPU load except the normal GNOME gui.

Now as I am writing the Processor load in the panel monitor applet is 0%, Memory 11% by programs, 22% by cache. And i have CPU Frequency monitor for each of the 4 cores set to 1.20 Ghz (the lowest possible value, i am not sure if this applet does really limit CPU usage). Running sensors in terminal gave me

temp1:       +26.8°C  (crit = +100.0°C)                  
temp2:        +0.0°C  (crit = +100.0°C) 

hddtemp /dev/sda at the terminal gave me

/dev/sda: WDC WD3200BEVT-75ZCT2: 46°C

All that fine but the laptop is Really hot i can feel it in the keyboard, mouse pad is painful to touch, and the fan is always spinning. I am also placing 2 small fans running on USB under the laptop right now and the laptop is lifted over the fans so it's well ventilated.

When I am running windows it doesn't get that hot except when there is a really big load on the CPU and this is keeping me away from using Linux for everyday tasks.

Actually I don't care much for speed as I can deal with low speed it's not going to shutdown abruptly.

So please if you can help me and tell me what are the possible causes, where should I start ?

share|improve this question
    
You mean: “ATI Mobility Radeon HD 4300” ? (The Radeon nnnn series are quite old.) –  JanC Oct 27 '10 at 21:38
    
@ JanC: Yeah that's right, I just corrected that. –  Tab Oct 28 '10 at 15:05
add comment

5 Answers 5

up vote 4 down vote accepted

There seems to be quite a few fan/heating issues with dell laptops. My first port of call would be to upgrade the bios.

I have had systems before that over heat and the bios update usually sorts the problem. UnFortunately it depends on dells support, please check the link below.

http://support.dell.com/support/downloads/driverslist.aspx?c=us&cs=19&l=en&s=dhs&SystemID=INSPIRON1564&os=BIOSA&osl=en&servicetag=&catid=1&impid=-1&dateid=-1&typeid=-1&formatid=-1&source=-1

Hope this helps some what.

share|improve this answer
    
I think that helped so much ! I updated the bios and now Heating is reasonable proportionate to the work load, the fan is not spinning all the time either and it's not getting very hot with regular tasks. I have to keep experimenting with that to see if that was the only cause. Thank you. –  Tab Oct 28 '10 at 15:07
add comment

If you're comfortable with doing it, it could well be worth taking the CPU apart and blowing the dust out of the fan and heatsink area. There are likely to be loads of guides around on the web, but the overall process is documented in the Dell service manual here. You should use proper compressed air to blow out the dust, and reapply thermal paste to the heat sink.

I did this to my Inspiron 1300 that was running very hot, and it worked absolute wonders.

share|improve this answer
    
I wish I can but that will void the warranty. I will try to ask the company to clear the fan for me. –  Tab Oct 28 '10 at 15:11
add comment

What kind of GPU do you have? Radeons are known to always run hot. Switching to the proprietary FLGRX driver fixes this.

There is an open bug for this on launchpad.

share|improve this answer
add comment

To lock the CPU to the lowest possible frequencies you can do this:

sudo tee /sys/devices/system/cpu/cpu0/cpufreq/scaling_max_freq < /sys/devices/system/cpu/cpu0/cpufreq/cpuinfo_min_freq

Or you can choose from the list of available frequencies by doing

echo [FERQ] | sudo tee /sys/devices/system/cpu/cpu0/cpufreq/scaling_max_freq

replace [FREQ] with one of the frequencies found by this command:

cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_available_frequencies

This might help in reducing the temperature. But actually i doubt that it is the processor thats causing the problem alone, even without graphics heavy applications a GPU can get very hot if the driver is not the correct one (perfectly optimized) so you might want to try out different drivers (if available, both open and closed source and different versions). Also try measuring the temperature when the computer is using cpu vs. using gfx. Try measuring temperature while running glxgears in full screen and then when running stress -c 5 to see which one makes the highest temperature.

An other thing that is important to think of is that you properly don't really know where the temperature sensors in you computer is.

The last this that i can think of is that the fan might not work correctly (not controlled correctly by the kernel) but if thats the case i will need to research some more ;)

share|improve this answer
    
I think it was the BIOS not updated. I did both tests after updating the BIOS and it gets hot with the stress test only (I think glxgears is not much load on the VGA card). But the fan was doing a good job and proportionate to the temperature. Is the stress test harmful in anyway ? –  Tab Oct 28 '10 at 15:10
    
No... stress -c X just starts X processes that calculates the square root of random numbers. The only way that it can be harmful is if it gets your computer to "melt down". –  Source Lab Oct 28 '10 at 15:34
add comment

I had a problem with Ubuntu 10.04 and 10.10 overheating and using all of my cpu and most of my ram. I scanned through these forums but didnt see anything that fit the description of my exact problem so I just started to tinker. I noticed in system monitor that XORG was doing most of the damage. I did a 'stop process' and that locked up my computer because the XORG manages the windowing system or something. Either way, did a hard reboot and my computer hasn't run unreasonably hot since, and cpu usage is where it should be. Hope this is helpful and not just dumb luck on my end.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.