Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I previously installed Ubuntu 10.04 on my laptop. That version installed wireless driver automatically and it worked well. But now I have installed Ubuntu 11.10 and cann't enable it's wireless. My laptop has a physical "wireless device switch" that for enabling its wireless, it has to switched on.

When I run "System Settings" >> "Additional Drivers" it announces "No proprietary drivers are in use on this system"

My laptop is Lenovo Ideapad U330 and below is some information about my laptop network specs:

>> sudo lshw -class network

*-network               
       description: Ethernet interface
       product: NetLink BCM5906M Fast Ethernet PCI Express
       vendor: Broadcom Corporation
       physical id: 0
       bus info: pci@0000:01:00.0
       logical name: eth0
       version: 02
       serial: 00:1f:16:20:ef:14
       size: 100Mbit/s
       capacity: 100Mbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm vpd msi pciexpress bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=tg3 driverversion=3.119 duplex=full firmware=sb v3.04 ip=192.168.1.100 latency=0 link=yes multicast=yes port=twisted pair speed=100Mbit/s
       resources: irq:47 memory:95600000-9560ffff

*-network DISABLED

   description: Wireless interface
   product: PRO/Wireless 5100 AGN [Shiloh] Network Connection
   vendor: Intel Corporation
   physical id: 0
   bus info: pci@0000:02:00.0
   logical name: wlan0
   version: 00
   serial: 00:1e:65:f7:51:0a
   width: 64 bits
   clock: 33MHz
   capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
   configuration: broadcast=yes driver=iwlagn driverversion=3.0.0-15-generic firmware=8.83.5.1 build 33692 latency=0 link=no multicast=yes wireless=IEEE 802.11abgn
   resources: irq:45 memory:94600000-94601fff

>> rfkill list all

0: ideapad_wlan: Wireless LAN

    Soft blocked: yes
    Hard blocked: no
1: ideapad_bluetooth: Bluetooth
    Soft blocked: no
    Hard blocked: no
2: phy0: Wireless LAN
    Soft blocked: yes
    Hard blocked: yes

3: hci0: Bluetooth
    Soft blocked: no
    Hard blocked: no

After applying iwlagn changes, although my laptop's "physical wireless switch" is on and I press Fn+F5 key combination, network manager cannot detect it and announces that wireless is disabled by hardware switch.

I use Ubuntu 11.10 as sole OS on my laptop.

share|improve this question
add comment

2 Answers

Your rfkill-list results indicate both a hard-block issue and soft-block issue.

Lets deal with the acer-wmi soft-block:

Try blacklisting the acer-wmi kernel module:

sudo nano /etc/modprobe.d/blacklist.conf

add blacklist acer_wmi as a new line at the bottom of this file.

then reboot.

After reboot rerun rfkill list all - hopefully your soft-block value is changed from "Yes" to "No".

As to the hard-block value of "Yes". This is a physical problem not a software problem.

There should be either a bios setting, Fn-key wireless toggle or a physical switch you need to use.

Sometimes these hardware block issues require the use of MS Windows - you boot into Windows, re-enable the wifi and then reboot into Ubuntu.


iwlagn

Sometimes the iwlagn kernel module can cause an issue. Try the following:

sudo rmmod -f iwlagn
sudo modprobe iwlagn 
sudo service network-manager restart

Another variation is:

sudo rmmod -f iwlagn
sudo modprobe iwlagn 11n_disable=1
sudo service network-manager restart

Wireless Switch

Since you mentioned that you see the error "wireless is disabled by hardware switch"...

On the Lenovo U330 laptop according to its manual:

An isotropic antenna system is built into the display for optimal reception, enabling wireless communication wherever you are. To enable wireless communications, do the following;

1 Slide the Wireless device switch latch to the right.

2 Press Fn + F5.

share|improve this answer
    
I'm on a Lenovo 3000 v200 and blacklisting acer_wmi fixed it for me. Thanks! –  Patrick Aug 25 '13 at 2:06
add comment

By simply entering the BIOS config at boot time and reverting to the default settings, I was able to reset the hardware block. I have no idea why this works, since I tried manually toggling the wireless device setting in the BIOS on and off.

(My system is a Lenovo U350 with a Intel 5100 AGN, running Ubuntu 12.04 64bit Desktop.)

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.