Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Im trying to install 11.10 from a USB drive. The installation process starts like it should but it gets to where it reads "Retrieving file 43 of 93" and it stays there. It's been there for over 15 minutes now with no change. Tried loading form CD with same issue.

share|improve this question
Isn't there the skip button to skip retrieving files from the web? If it is, but you cannot click it, try clicking it before it freezes. Skip the operation when it starts at "retrieving file 1." – Richard Rodriguez Jan 24 '12 at 16:08
have you tried to install ubuntu without network connection? you can install that packages later after you finished the installation process – zurdo Jan 24 '12 at 16:50
Had the same problem and disconnecting the Network Adapter solved it. – Nadeem Muhammad Mar 22 '13 at 15:57

If you have this problem installing inside of VMWare (I am using Fusion), then simply disconnect the network adapter in the VM. That immediately allowed my installation to continue.

share|improve this answer
Can you include a screenshot showing how to do this? – Eliah Kagan Oct 6 '12 at 0:36
Thanks, it worked for me. I was using Oracle VM Virtual Box – Goaler444 Apr 24 '13 at 17:07

If you encounter this problem. Before installing uncheck "Check For Updates" and please disconnect your internet connection

Unchecking Updates

After the system reboots, use Update Manager to install the latest updates or run sudo apt-get update&&sudo apt-get upgrade in the terminal

share|improve this answer

Disconnect your Computer from the Internet (pull out the cable) and start the installation a second time. When done, reconnect to the Internet → install system updates as usually ...

share|improve this answer

I have faced the same problem but I wasn't able to install after unchecking the Check For Updates option. I have tried the following way and managed to install after that:

  1. Insert CD and select Try Ubuntu option.
  2. Now check if the Internet is working or otherwise, to ensure there is no problem with the Internet connection.
  3. Select the option Install Ubuntu in the desktop during live session.

After that, you should now be able to install without any problem.

share|improve this answer

Click on the "Cancel" option to proceed. It'll most likely then skip the immediate culprit file and proceed to the next.

You could in conjunction with this do some of the other answers such as disconnect the NIC (for the VM's remove the configured NCI).

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.