Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.
$ sudo iwconfig
lo        no wireless extensions.

eth0      no wireless extensions.

wlan0     IEEE 802.11bg  ESSID:off/any  
          Mode:Managed  Access Point: Not-Associated   Tx-Power=0 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off

pan0      no wireless extensions.

$ 

This is what pops up when I click the two computers icon

alt text

What should I do to get Wifi working on this machine?


$ sudo ifconfig wlan0 up
SIOCSIFFLAGS: No such file or directory
$

$ lspci | tail
00:1d.1 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #2 (rev 03)
00:1d.2 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #3 (rev 03)
00:1d.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #1 (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev 93)
00:1f.0 ISA bridge: Intel Corporation ICH9M LPC Interface Controller (rev 03)
00:1f.2 SATA controller: Intel Corporation ICH9M/M-E SATA AHCI Controller (rev 03)
00:1f.3 SMBus: Intel Corporation 82801I (ICH9 Family) SMBus Controller (rev 03)
01:00.0 VGA compatible controller: ATI Technologies Inc M92 LP [Mobility Radeon HD 4300 Series]
09:00.0 Ethernet controller: Marvell Technology Group Ltd. 88E8040 PCI-E Fast Ethernet Controller (rev 13)
0c:00.0 Network controller: Broadcom Corporation BCM4312 802.11b/g (rev 01)
$
share|improve this question
    
The Broadcom driver was missing, it works now, thanks everyone. –  Lazer Oct 29 '10 at 18:14
add comment

8 Answers 8

It is likely that the network-manager state got corrupted. Open the file /var/lib/NetworkManager/NetworkManager.state. It should look something like this:

[main]
NetworkingEnabled=true
WirelessEnabled=true
WWANEnabled=true

Change any from 'false' to 'true' to re-enable networking. It may work better if you first stop NetworkManager:

sudo stop network-manager

And start it again once done.. Or reboot

This happened occasionally after wakeup in Lucid. In Maverick this should be fixed.

share|improve this answer
    
all the states were already set to true. disabling and restarting has no effect. –  Lazer Oct 28 '10 at 5:04
    
In this case, try to remove and re-insert the wireless kernel module with rmmod and modprobe. –  txwikinger Oct 28 '10 at 13:09
    
What is the module name? –  Lazer Oct 29 '10 at 17:00
    
This depends on your wifi card. In my case it is iwl4935, I believe. –  txwikinger Oct 29 '10 at 20:13
add comment

Try this:

  • Install rfkill -> sudo apt-get install rfkill
  • Give this command in terminal -> rfkill unblock all

Your wireless will work instantly, I hope. I guess you have a Intel wireless card and an Hp laptop, one of them at least.

share|improve this answer
    
rfkill unblock all does not change anything. I think it is already enabled, but not able to search for the network. I am able to connect to the network using Vista on the same machine though. –  Lazer Oct 28 '10 at 5:05
    
Can you tell me which card is? –  skalka Oct 28 '10 at 7:58
1  
I have this problem on lucid, and this works for me, but the unblock all command only works when I disable wireless on my laptop first (I've got a hardware switch). So I switch it off, run sudo rfkill unblock all, then switch it on, and it works every time for me. (Dell Inspiron 1420n) –  user1477 Oct 30 '10 at 21:19
add comment

Check this one out. It's for BROADCOM CARDS ONLY This worked for me. The button wouldn't work at all, and it wouldn't detect any wireless networks... But I did this, and rebooted, and it works perfectly.

http://techie-buzz.com/foss/wifi-ubuntu-install-broadcom-drivers.html

You might have to mess with the terminal commands, depending on where you put the downloaded files. I kept them all in my "Downloads" folder.

My commands ended up looking like the ones below

sudo b43-fwcutter -w /lib/firmware '/home/tsarprodigy/Downloads/wl_apsta-3.130.20.0.o'

Then

tar xfvj /home/tsarprodigy/Downloads/broadcom-wl-4.80.53.0.tar.bz2'

And finally,

sudo b43-fwcutter --unsupported -w /lib/firmware broadcom-wl-4.80.53.0/kmod/wl_apsta_mimo.o

Now all you have to do is restart and it should work just fine!

You're welcome, and thanks for reading...

share|improve this answer
add comment

I did rfkill list and it should no for soft and hard blocks. I still ran rfkill unblock wifi and I was able to see networks again. It has happened to me for the last 2 distros in this manner.

HP DV9000 Laptop

share|improve this answer
add comment

On my Acer 3500 running ubuntu 10.10 the wireless suddenly stopped working after a screwy suspend/hibernation/power-off event. No amount of reboots would renable it. rfkill said the wireless was turned off at the switch, though the light indicating the wireless card is turned on remained on. rfkill unblock all had no effect.

$ rfkill list
0: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: yes

Network manager indicator said "wireless disabled" instead of "device not ready" as in the question. It was greyed out and not possible to change it to enabled. After a couple hours of troubleshooting and research I finally discovered the solution (for me):

sudo rm /dev/rfkill && sudo reboot

Kudos to Philip K. Adetiloye for taking the time to write about in Ubuntu Wireless disabled: SIOCSIFFLAGS: Operation not permitted. (The error message refers to the output of sudo ifconfig wlan0 up when /dev/rfkill is in the broken state.)

share|improve this answer
    
sudo rm /dev/rfkill This worked great for me, thanks! –  Ronshere Oct 6 '13 at 5:09
add comment

I had this (or similar) issue in Ubuntu 10.04. For me, right clicking the network-manager status icon (the two computers), and selecting "Enable wireless" solved the problem for that session.

I had to do this every time I started the machine, though, the solution was workable for me. I never cared to investigate further.

share|improve this answer
    
that checkbox is already enabled. –  Lazer Oct 28 '10 at 5:03
add comment

I've seen this happen sometimes, and just right-clicking on the Network Manager applet and re-checking "Enable Wireless" (and/or "Enable Networking") has solved it for me in the past.

share|improve this answer
add comment

I had a very similar if not the exact same problem. It seems to be that the WiFi button (rfkill hard block) is not syncing with the rfkill soft block. I had this problem since an Ubuntu update just before Christmas. Before it worked perfectly.

I solved the issue by making sure the hard and soft block are both set to no. You can check this by running rfkill list all in a terminal.

  • The hard block you can change by pressing your laptop's WiFi button
  • The soft block you can override by entering rfkill unblock wifi

Check with rfkill list all if both values are set to no and your wireless should work again.

If you still have problems I have written up a bit more detailed blog post.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.