Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I run oneiric with fluxbox as the window manager, and gnome-terminal appears to disregard gtk theme. The theme support does work in other gtk applications (for example, in gthumb and in firefox), but changing the theme makes no difference for gnome-terminal. I have oneiric, and I use lxappearance to change the theme. Am I wrong in assuming that gnome-terminal is a gtk application? Or is the problem elsewhere?

  • Note that the checkbox "Use colours from system theme" in gnome-terminal configuration does not solve the problem, nor it is supposed to, since I am interested in the look and size of the menu, and the tabs, not their colour. ]

  • LXAppearance version is 0.5.1, and so it appears that it is GTK3 compatible. It even creates the file gtk-3.0/settings.ini in the home directory which contains the selected settings. This, I think, rules out http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=631897 as a possible cause.

share|improve this question

2 Answers 2

up vote 1 down vote accepted

LXAppearance is the culprit after all. See https://bbs.archlinux.org/viewtopic.php?id=125540

I tried copying the configuration file created by it to .config/gtk-3.0. After restarting gnome-terminal, the menus disappeared completely (or to be precisely everything is nearly zero-sized, and there is text). After commenting the .config/gtk-3.0/settings.ini line-by-line the culprit is gtk-font-name. Anyhow, this proves that gnome-terminal is a GTK3 app which does read the settings.

Solution was to install gnome-themes-standard and edit .config/gtk-3.0/settings.ini to say "gtk-theme-name=Adwaita" (it is the only theme in the package, but it suits me fine).

Final remark: confusingly in the directory /usr/share/themes many themes have gtk-3.0 subfolder without being GTK3 themes. I hope it is of help to someone.

share|improve this answer

This may not be a solution for you if you're trying to avoid too many Gnome dependencies, but I solved it by making sure gnome-settings-daemon was starting in my .xinitrc: after starting that, all my GTK2/3 applications suddenly paid attention to a whole load of settings they'd previously been ignoring. You can then use gnome-tweak-tool to change themes (or possibly lxappearance and then log out & in again?).

I don't know where it lives on Ubuntu, but I found it in /usr/lib/gnome-settings-daemon/gnome-settings-daemon on my Arch system (it used to live in the $PATH before Gnome 3).

Hope that helps!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.