Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have to different but similar monitors.

According to nvidia-settings my main monitor is running at 59.93 HZ while the other runs at 59.88 HZ.

In X Video settings I have enabled VSync and that it should sync to my primary monitor. This results in video tearing on my secondary.

Is there a way to specify a refresh rate at which both monitors should run?

NVIDIA-setings

share|improve this question
    
I think you mean Hz, not MHz... –  psusi Jan 24 '12 at 16:16
    
indeed, you are right. –  Christian Smorra Jan 24 '12 at 17:29
    
What happens if you set them both manually to 60Hz? You have to first change the resolution from Auto, then set the refresh rate. –  Tom Brossman Apr 1 '12 at 21:03
    
@Tom Brossman , where would I do that in the Nvidia drivers? –  Christian Smorra Apr 5 '12 at 14:59
add comment

1 Answer

up vote 1 down vote accepted

Start up the NVIDIA control panel, called 'NVIDIA X Server Settings'

That brings up a window like this:

NVIDIA Settings window

Yours will look different, but the instructions are the same.

  1. Click on 'X Server Display Configuration'(top left).
  2. Go down to 'Resolution:'(bottom right).
  3. The first item is 'Auto'. Change that manually to your native resolution. After doing this note that you can now change the refresh rate. (refresh rate can't be changed with resolution set to 'Auto')
  4. Change the refresh rate to 60Hz, like shown in the image.
  5. Repeat steps 3 & 4 for the second monitor.
  6. Save and quit, you should now have set the refresh rate manually to the same value for both monitors.
share|improve this answer
    
thank you for your reply Tom but unfortunately that's not an option for twin view because it's grayed out i.e. unchangeable, see imgur.com/Ehy8g –  Christian Smorra Apr 5 '12 at 23:40
1  
@ChristianSmorra Sorry that didn't work. Have you tried editing your xorg.conf file directly? It's in /etc/X11. There may be a good reason you can't access the setting, so make sure you back up your old file and understand how to restore it with no GUI if things go wrong. –  Tom Brossman Apr 6 '12 at 6:55
1  
@ChristianSmorra I just looked at your screenshot and Resolution: is set to 'Auto'. You did try setting it manually, right? It is supposed to be greyed out until you manually set the resolution, (see steps 3 & 4 of my answer above). –  Tom Brossman Apr 6 '12 at 7:01
    
thanks Tom, appreciate your help! By setting the resolution manually I could change the refresh rate to 60 HZ and the tearing is gone. –  Christian Smorra Apr 6 '12 at 9:31
    
@ChristianSmorra Glad to help. I've edited my answer to make this clearer. –  Tom Brossman Apr 6 '12 at 9:41
show 1 more comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.