Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have one PC where I have my main screen using 1024x768 resolution and my another screen using 1980x720 resolution.

But why its so slow, is there any way to make it faster like normal?

I had the same issue with Fedora 15 like now I have with Ubuntu.

Follow up:

$ lspci | grep VGA
00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)

$ export DISPLAY=:0.0 && glxinfo | grep -i direct
direct rendering: Yes
share|improve this question
Are you using any proprietary graphic drivers? – subeh.sharma Jan 24 '12 at 13:21
up vote 1 down vote accepted

Please check if: a) Your OS sees Your graphic card, and identifies it properly:

lspci | grep VGA

b) You have hardware acceleration enabled:

glxinfo | grep -i direct

Please give the output of those two in Your question. (if You do not have glxifno install mesa utils:)

sudo apt-get install mesa-utils


share|improve this answer
@Milsery: edited as above. – YumYumYum Jan 24 '12 at 13:37
Hmmm... well it looks like Your VGA card works well. In the latest Ubuntu with Unity I had the same issue, it worked very slow. Which verion of ubuntu do You use? And one more thing: is Your VGA card powerful enough to work on the settings You have (resolution, 3d effects etc.)? – Misery Jan 24 '12 at 13:41
With out dual head, it works perfect with effects and video test etc. But once its dual head and random resolution it start happening that slowness, i have same with (Fedora 15 before). I am using Ubuntu 11.04 (GNU/Linux 2.6.38-8-generic x86_64). – YumYumYum Jan 24 '12 at 13:49
Try to set very small resolution on both screens. Does it help? – Misery Jan 24 '12 at 14:09
It looks like Your card has not enough 'power' to work in such resolution on both monitors. First please check if You have enabled all required options in BIOS - check Your mainboard or VGA card manual for details. (search for options like surround view, dual monitor support etc.) BE CAREFUL WHILE CHANGING ANYTHING IN BIOS. One more thing that comes to my mind is to check frequency on which Your monitors work – Misery Jan 24 '12 at 16:55

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.