Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm trying to start my container node01. It was working before and I just can't understand why all my containers (3) stopped working in one time after reboot. Actually they not starting. After lxc-start -n node01 it just hangs and console don't show startup process. Pressing the keys just reflect symbols but nothing happening.

I have Ubuntu 11.10 oneiric 3.0.0-14-server x86_64 lxc-start

In /var/log/syslog next lines shows after

Jan 24 11:19:14 us1 kernel: [11733.905542] device veth1xlPzk entered promiscuous mode
Jan 24 11:19:14 us1 kernel: [11733.905970] ADDRCONF(NETDEV_UP): veth1xlPzk: link is not ready
Jan 24 11:19:14 us1 kernel: [11734.053982] ADDRCONF(NETDEV_CHANGE): veth1xlPzk: link becomes ready
Jan 24 11:19:14 us1 kernel: [11734.054016] br0: port 2(veth1xlPzk) entering forwarding state
Jan 24 11:19:14 us1 kernel: [11734.054019] br0: port 2(veth1xlPzk) entering forwarding state

Ping to container is working, but I can't ssh to it.

Only after lxc-stop -n node01 from another terminal my first terminal stops hangs.

in /var/log/syslog shows next lines:

Jan 24 11:19:25 us1 kernel: [11744.448111] eth0: no IPv6 routers present
Jan 24 11:19:25 us1 kernel: [11744.496065] veth1xlPzk: no IPv6 routers present
Jan 24 11:20:15 us1 kernel: [11794.424915] br0: port 2(veth1xlPzk) entering forwarding state
Jan 24 11:20:15 us1 kernel: [11794.426315] br0: port 2(veth1xlPzk) entering disabled state

How to force it working?

share|improve this question
    
I see nothing here that would indicate a problem. Can you open a console to your containers? –  Stephen Eilert Feb 2 '12 at 14:33
    
I was not able to. But it is too late to seek problems, I just destroyed those containers. Somehow the problems was with all of them. –  BBK Feb 11 '12 at 9:57

1 Answer 1

up vote 2 down vote accepted

The answer to this question was provided in the comments.

The solution was to back up the data, destroy the LXC containers,and start fresh.

I just destroyed those containers. Somehow the problems was with all of them.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.