Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I can not display file coded with GBK. In gconf-editor of gnome 3.2 , I can not find encoding item of gedit . How to set it ? thanks

share|improve this question
    
What is the output of locale and locale -a? –  enzotib Jan 24 '12 at 8:58

2 Answers 2

up vote 16 down vote accepted

I don't have a file encoded in GBK to test the solutions, but do try them.

Option 1: Run gedit and then open the file:

  • run gedit

  • click open

  • select in the encoding combo "add" and add GB18030 (or GBK)

  • select that encoding in the combo

  • select the file

Option 2:

  • install and run gconf-editor

  • Find /apps/gedit-2/preferences/encoding key "auto_detected" and set it to:

    [CURRENT,GB18030,GBK,GB2312,UTF-8,UTF-16]
    

Remember to backup the previous value of auto_detected!!

Option 3: Using dconf (the "newer" gconf, used in ubuntu)

dconf read /org/gnome/gedit/preferences/encodings/auto-detected

Save the result (backup)!

dconf write /org/gnome/gedit/preferences/encodings/auto-detected "['CURRENT', 'GBK', 'GB18030', 'GB2312', 'UTF-8', 'UTF-16']"

Sources:

To reset it to default: a) use the option you backed up from dconf read command

or b) try:

dconf reset /org/gnome/gedit/preferences/encodings/auto-detected
share|improve this answer
    
Thanks a lot ! Detailed and helpful instructions. –  waterloo2005 Jan 24 '12 at 11:29

If you want do it quick then install medit. All works from the box.

If you still want use gedit then you need do some work:

  1. Set auto-detect

    gsettings set org.gnome.gedit.preferences.encodings auto-detected "['UTF-8', 'GBK', 'CURRENT', 'ISO-8859-15', 'UTF-16']"
    
  2. Install plugin for manual choose encoding. Really useful, especially when auto-detect don't detect encoding properly

"Change encoding" plugin for gedit v3

# Download plugin
mkdir -p /tmp/encoding
cd /tmp/encoding
wget https://aur.archlinux.org/packages/ge/gedit-encoding-plugin/gedit-encoding-plugin.tar.gz
tar -xzvf gedit-encoding-plugin.tar.gz

# Copy to plugins directory
mkdir -p ~/.local/share/gedit/plugins
cp /tmp/encoding/gedit-encoding-plugin/encoding.plugin /tmp/encoding/gedit-encoding-plugin/encodingpy.py ~/.local/share/gedit/plugins

# Remove /tmp/encoding
rm -Rf /tmp/encoding

Then run gedit. Choose Edit->Preferences->Plugins(tab)->Check "Encoding" checkbox. After you do that you can find "Encoding" in menu "File"

Plugin description: https://aur.archlinux.org/packages/gedit-encoding-plugin/

Plugin for gedit v2. Same author as in plugin above: http://bugzilla.gnome.org/attachment.cgi?id=108326 or plugin for gedit v2 by another author: http://petrstepanov.wordpress.com/2010/09/29/gedit-encoding-plugin/

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.