Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

At rebooting my Lenovo ThinkPad T420s after the recent updates coming last Friday (not sure), I got severe graphical problems: could almost not use unity.

I switched from Intel to Nvidia and loaded the restricted driver. Then I saw some more updates coming and applied them.

When I switched back to Intel graphics (integrated), I got only Unity 2D. So no 3D any more on Intel.

Any hints other than waiting for another update that fixes the issues?

share|improve this question
    
Did you remove the restricted drivers and the xorg.conf generated for them? –  Bruno Pereira Jan 24 '12 at 10:23
    
Not explicitly, but I tried to clean up with: $ sudo apt-get purge xserver-xorg $ sudo apt-get install xserver-xorg xserver-xorg-video-all $ sudo reboot (from hint in askubuntu.com/questions/79403/…). It looks like it tries unity 3d at login but backs down to unity 2d. –  Dag Rende Jan 25 '12 at 7:26

1 Answer 1

Probem solved: I had power tuned my ubuntu with the hint in http://ubuntuforums.org/showthread.php?t=1872633. But some of the packages installed in that instruction interfered with the kernel or intel driver update, and 3d stopped working. When I removed the PPA-sources and packages in the article above and rebooted, 3d worked again.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.