Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Whenever I boot into GNOME Classic (I am following this guide to set up Edgebound Desktop) my main view is just a top bar with no clock or date on it, but it says "File Edit View Go Bookmarks Help" and I have the side dock which is from Unity, but other than that it doesn't seem like GNOME 3 is working properly and I can't figure out why. I also tried logging into just GNOME: same problem except no unity side bar. Any help or advice would be appreciated.

The problems are as follows:

  • Nautilus Menu is still present, no clock, etc shows up in the bar just "File Edit View, etc"
  • The side bar is the same as Unity's and behaves the same way

In other words it's acting as if Gnome 3 isn't present at all even though that's the session I am in.

More details - running this with NVIDIA restricted drivers, dual monitor setup set for TwinView

Gnome Classic Gnome Classic Gnome Gnome

share|improve this question
    
It sounds like you are getting the Nautilus menu to still display at the top of your screen even though there isn't supposed to be anything there (Edgebound is supposed to remove the top panel). Can you edit your question to describe in more detail what other problems you are encountering? –  WarriorIng64 Jan 24 '12 at 3:46
    
Unity loads fine in Ubuntu (Unity session) - if I run unity --reset in Gnome 3 it brings back the time and stuff and then it makes 2 side bars that overlay each other. –  eWizardII Jan 24 '12 at 3:47
    
I have added more details on the issue. –  eWizardII Jan 24 '12 at 3:51
    
Okay, so looking back at the original article, it does say that GNOME Classic is completely replaced by Edgebound. That is to be expected. GNOME Shell should still work fine, though. In either case, you shouldn't be getting Nautilus's menu to appear at the top of the screen (at all in Edgebound, or in place of the top panel in GNOME Shell). I'll edit the title appropriately. –  WarriorIng64 Jan 24 '12 at 3:57
    
Added shots of both sessions - Gnome and Gnome Classic, I just logged in a gain to do the screenshot and now the bar doesn't show up. But classic if I use the super key I can get the menu to show up. –  eWizardII Jan 24 '12 at 4:18

3 Answers 3

From the artist's comment in his DeviantArt page:

Get access to a terminal and type rm ~/.config/autostart/compiz.desktop

Thanks for finding this bug. It has nothing to do with the theme at all. It has to do with compiz now trying to start in Gnome-Shell which obviously will break it. I this fix to the restore script.

Hopefully, that will help solve your broken gnome-shell problem.

And, regarding the Nautilus menu on top of your desktop, you can fix that by disabling file manager handling the desktop.

To do that, you can try gnome-tweak-tool Install gnome-tweak-tool.

Open gnome-tweak-tool and turn off the switch that says 'Have file manager handle the desktop'.

enter image description here

share|improve this answer
    
Thanks for the help unfortunately that didn't change anything. In Ubuntu classic I don't have the bar anymore which is the way it should be when the theme works, but still nothing else is showing up like Gnome 3 - I even tried Gnome 3 without the theme same problem. –  eWizardII Jan 24 '12 at 4:55

Remove gnome-shell and reinstall it.

sudo apt-get remove gnome-shell
sudo apt-get install gnome-shell

It fixes the issue for me.

share|improve this answer

You may want to purge AWN in unity and then delete/reinstall gnome 3. I have this problem too but haven't tried this yet

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.