Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

i7-2670QM, x64, win7+ubuntu11.10+kubuntu11.10

Since yesterday i cannot install anything on kubuntu, because the package manager starts and then error: some other manager is working.
But there is nothing, tried it just after start for updating the newer kernel, no go. What can i do?

Also on ubuntu Celestia shows its start-sreen, is loading something and fade away into nirvana. Has somebody an idea, what to do to get this running?

share|improve this question
add comment

2 Answers 2

up vote 1 down vote accepted

It is solved: i startet from terminal sudo apt-get install startup to edit grub2,(editing is not working!) and get i should use because of problems: sudo dpkg --configure -a _ It worked for some time and then all was ok. Problem seems to be a pending update of nouveau, a NVIDIA-driver. There are 2 graphic cards, one integrated Intel and a seperate NVIDIA, which is still not at work, because of not installed "switcheroo" or similar to use a hardware switch on front for choosing one (powersafer)._Gnome-system-monitor works like "task-manager in win", but didn´t show the damaged update.

share|improve this answer
    
A friendly advice: Do not install this startup, it is nearly useless! but creates trouble mostly. It is no part of solving, only on the way. –  Marek Jan 27 '12 at 0:52
add comment

This is probably caused by some package manager crashing and failing to remove the lock file which is supposed to prevent other package managers from making concurrent changes to the system.

Make sure no package managers running and remove /var/lib/dpkg/lock file if it exists (as root)

share|improve this answer
    
I removed the lock file, but same as before. At start is a message for updating needed, but afterwards disapeared. First removed lock from ubuntu, but it was still empty there, so also done in kubuntu. This update program must run, but is not to see. –  Marek Jan 24 '12 at 2:45
    
Isn´t there something like task-manager? Strg+Alt+Del stops the session, but found nothing for searching running programs. To see on destop is only Muon-Paketverwaltung. –  Marek Jan 24 '12 at 3:11
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.