Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am running LibreOffice 3.4.3 with Sun Presenter Console 1.0.3 on Ubuntu 11.10 on a Dell Inspiron 1545 laptop.

I would like to be able to view the notes for the current slide on my laptop while the slide is being presented full-screen through the attached projector. Instead, all I can get on the laptop during a presentation is the normal view, where I have to manually advance to get from one slide to another.

Is there a way to configure my settings so the two displays stay in sync on the same slide but one shows notes and the other doesn't?

share|improve this question
Did you edit your slideshow settings? Also, I'm a bit confused; are you getting the presenter console to work at all? – RolandiXor Jan 27 '12 at 18:16
I don't know what the Presenter Console is supposed to look like. What I am seeing on my laptop is as though I'm not in a slide show at all. I have tried fiddling with slideshow settings but am not able to get a change in the outcome. – espertus Jan 27 '12 at 22:22
The presenter console stopped working for me a couple of years ago. Questions on the OOo forums went unanswered. There don't seem to be any error messages or anything. It's a shame, too. I used to love it. – Scott Severance Jan 28 '12 at 6:32
To see how the Presenter Console is supposed to appear, view the screenshot in the blog posting: – CentaurusA Feb 1 '12 at 14:42
up vote 8 down vote accepted

espertus, I had exactly your problem. on exactly the same software you have. This is how I solved it:

  1. get rid of everything that wasn't ubuntu-provided (including the Sun Presenter Console)

  2. install the ubuntu-provided console with sudo apt-get install libreoffice-presenter-console

  3. reboot

Note that bullet 3. is essential. I don't know why, but if you don't reboot it will never work (just restarting LO won't work).

share|improve this answer
Perfect! Once I rebooted, the presenter console was indeed fully operational. I have spent quite a bit of time today trying to "fix" LibreOffice Impress. Your correct answer was very welcome! Plus 1 from me (and, I would hope, the bounty for the question). – CentaurusA Feb 1 '12 at 1:07
I did what you suggested, fiddled around, and the Presenter Console worked! I'm not sure what I did differently this time than in the past and don't know if it will keep working, but thank you very much. I'm happy to give you a chunk of my karma. – espertus Feb 1 '12 at 18:24
This approach doesn't work for me. – Scott Severance Apr 5 '12 at 2:49
Still useful in Ubuntu 14.04.2. Though I did not need to reboot. – gkephorus Nov 1 '15 at 18:38

Unfortunately, the Presenter Console is completely broken and has been for a couple of years. It appears to me to be abandonware, and getting Sun to fix anything was nigh impossible (I don't know about Oracle). It doesn't work on any computer I've tried, across multiple versions of Ubuntu and LibreOffice/OpenOffice. It's a shame that it no longer works, as I found it really useful.

Here's the workaround I've found: Install pdf-presenter-console. It takes a PDF file and presents it. You can easily export Impress presentations to PDF, although there are a few features you can't use in such a case.

Advantages of pdf-presenter-console:

  • Uses PDF files.
  • Works as advertised.
  • Includes a timer.


  • Can only use PDF files.
  • No support for notes.
  • No support for animation
  • The timer can't be disabled, though if you pass -d 0 it won't run.
  • Can only be launched from the command line unless you make your own custom .desktop file.
share|improve this answer
Thanks for cluing me in on Presenter Console and letting me know about pdf-presenter-console. Unfortunately, the lack of support for notes and animation makes it practically useless for my purposes. – espertus Jan 28 '12 at 17:37
"Unfortunately, the Presenter Console is completely broken and has been for a couple of years." Well, clearly, given the answer above, this isn't true. It works without a hitch in LO 3.4.4 under Windows so it makes sense that there's a way to get it to work in Ubuntu. As the other answer explains. – Warrick Feb 15 '12 at 10:18
@Warrick: Actually, I stand by my statement. Davide's answer makes no difference. The Presenter Console still doesn't work after following his instructions. So, my answer stands. Also, whether it works on Windows has no bearing on this discussion. We're using Linux, so Windows software doesn't help. – Scott Severance Apr 5 '12 at 2:53

I used Presenter Console last night and it worked just fine. I am using Ubuntu 12.04LTS and Libre Office I down loaded the Presenter from a link on the LO site (The document foundation), and used LO Extension Manager to get Presenter into my Libre Office.

I had my LAPTOP connected using it's VGA port which was cabled to the projectors DVI imput.

My laptop screen was two images, the larger being the Projected image and the smaller image was the next image in the Impress slide show sequence, I also has a clock for the current time and a clock for the presentation time. I wish I had gotten a screen shot as Presenter Console does not work unless your computer senses the second screen output. It would be nice to see some screen shots of how it works.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.