Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm fresh Ubuntu user.

My PC is pretty fast (Phenom x4 3.6GHz/HD5770/4GB RAM) so i was very disappointed when firstly saw how laggy is the interface - lags when I try to move any window.

I think my problem is caused by graphics drivers but i have no idea how to resolve it...

I tried to install and uninstall fglrx on every way I found but it didn't help. It's the same both on x64 and x86 Ubuntu.

(Sorry if my English is bad ;) )

I installed Propierty Drivers from Ubuntu system settings (jockey?) And from AMD website through console - both were the same laggy.

I think those were the newest one - AMD Catalyst™ 11.11 Proprietary Linux x86 Display Driver

I have noticed that everything runs smoothly when I run Ubuntu from LiveUSB

Setting "Sync to VBlank" to off in Compiz Manager doesnt help too...

share|improve this question
    
I installed Propierty Drivers from Ubuntu system settings (jockey?) And from AMD website through console - both were the same laggy. –  user43261 Jan 23 '12 at 19:42
    
What versions? (please add all this information to the question instead of adding comments, it makes your question better for others to see and understand) –  Bruno Pereira Jan 23 '12 at 19:44
add comment

3 Answers

Try to replace the Device block in your xorg.conf file with this one:

Section "Device"
 Identifier "ATI Radeon"
 Driver "ati"
 Option "AccelMethod" "EXA"
 Option "MigrationHeuristic" "greedy"
 Option "AccelDFS" "true"
 Option "EnablePageFlip" "true"
 Option "EnableDepthMoves" "true"
EndSection

It's working for me and I have very smooth windows!

Also save Sync to VBlank off and auto frame rate count in composite off too.

share|improve this answer
add comment

Initially, I would assume this is an apparently typical error with fglrx and compiz' 'sync to vblank'.

First, download 'CompizConfig Settings Manager', either through the Software Center or by running 'sudo apt-get install compizconfig-settings-manager' in a terminal. Next, open the manager through the dash and hit the OpenGL icon. You should see an option for 'Sync To VBlank' there. Try disabling it and see if it does any good. It did the trick for me.

share|improve this answer
    
Nope, doesn't work for me - still laggy... ;/ –  user43261 Jan 23 '12 at 20:38
add comment

I had the same issue here and I solved it by installing the original driver from ATI by downloading it from the official site.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.