Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I already have Sun Java (not OpenJDK) installed, but I'm still having audio issues. OpenJDK didn't display the slides, which was fixed by Sun Java, but the audio was bad in both of them. Is there any fix? I have been looking for a long time.

share|improve this question
also an issue in 12.04, mostly with microphone/input. – amc May 7 '12 at 23:22

It's a stupid problem, but I've found a work-around (not a fix).

  1. Log into eLive client and run the audio wizard

    a) don't worry about the audio at this point, just make sure the correct input/output devices are selected.

  2. Install skype from the partner repository:

    a) open the ubuntu software centre, and select Software Sources... from the "Edit" menu.

    b) click on the "Other Software" tab and check "Canonical Partners":

    software sources

    c) open a terminal and update your software list: sudo apt-get update

    d) re-open the ubuntu software centre, search for skype and install (or use the terminal: sudo apt-get install skype)

  3. Adjust audio levels using skype:

    a) log in (create account if need be)

    b) open the Options pane:

    skype menu

    c) Select "Sound Devices" from the list on the left, and ensure the box "Allow Skype to automatically adjust my mixer levels" is checked.

    enter image description here

    d) Make a test call to check your speaker/mic settings.

In addition, you may need to clear the java cache using the "Oracle Java 7 Control Panel":

a) On the "General" tab, in the "Temporary Internet Files" section, click "Settings"

b) Next, click "Delete Files..."

c) Make sure the "Cached applications and applets" box is checked and click "OK"

Now when you log into eLive your audio should be working fine.

Tested and working on Ubuntu 12.04 Precise 64-bit

share|improve this answer
NOTE: that I am using Oracle Java 7 – amc May 8 '12 at 22:26

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.