Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Been banging my head against the wall and god knows what. Would appreciate some help on this one.

I have Ubuntu 11.10, 64bit installed with Firefox 9.0.1 and Google Chrome 16.0.912.75.

Flash was installed via Flash-Aid (Firefox extension) earlier and was working fine. About 7 hours back, I hit a bug on one of my programs and wanted to check whether it was a player issue. I decided to switch to a stable release via Flash-Aid. For some reason, the switch didn't work, so I tried to revert back to the beta release once again. No luck either.

The funny thing is both Firefox and Chrome report that the flash player is installed.

Google Chrome Plugin Tab

Flash - Version: 11.2 r202

Shockwave Flash 11.2 r202

Name: Shockwave Flash

Version: 11.2 r202

Location: /usr/lib/mozilla/plugins/


MIME types:

MIME type Description File extensions

application/x-shockwave-flash Shockwave Flash


application/futuresplash FutureSplash Player


Firefox Plugin Tab

Shockwave Flash

Shockwave Flash 11.2 r202

Location of

$ locate

$ ls -altr /usr/lib/firefox-
lrwxrwxrwx 1 root root 42 2012-01-23 19:43 /usr/lib/firefox-addons/plugins/ -> /usr/lib/mozilla/plugins/

$ ls -altr 
-rw-r--r-- 1 root root 19M 2011-12-17 20:32 /usr/lib/mozilla/plugins/

$ ldd 
/usr/lib/mozilla/plugins/ => (0x00007fffe2dff000) => /usr/lib/x86_64-linux-gnu/ (0x00007f7756633000) => /usr/lib/x86_64-linux-gnu/ (0x00007f77562fb000) => /usr/lib/x86_64-linux-gnu/ (0x00007f77560e7000) => /usr/lib/x86_64-linux-gnu/ (0x00007f7755e82000) => /lib/x86_64-linux-gnu/ (0x00007f7755c7a000) => /usr/lib/x86_64-linux-gnu/ (0x00007f7755a6f000) => /usr/lib/x86_64-linux-gnu/ (0x00007f7755864000) => /usr/lib/x86_64-linux-gnu/ (0x00007f775562a000) => /usr/lib/x86_64-linux-gnu/ (0x00007f77553fd000) => /usr/lib/x86_64-linux-gnu/ (0x00007f77550c5000) => /usr/lib/x86_64-linux-gnu/ (0x00007f7754ea6000) => /usr/lib/x86_64-linux-gnu/ (0x00007f7754ca1000) => /usr/lib/x86_64-linux-gnu/ (0x00007f7754a9c000) => /usr/lib/x86_64-linux-gnu/ (0x00007f7754861000) => /lib/x86_64-linux-gnu/ (0x00007f7754643000) => /lib/x86_64-linux-gnu/ (0x00007f775443f000) => /usr/lib/x86_64-linux-gnu/ (0x00007f7753e03000) => /usr/lib/x86_64-linux-gnu/ (0x00007f7753b50000) => /usr/lib/x86_64-linux-gnu/ (0x00007f775392e000) => /usr/lib/x86_64-linux-gnu/ (0x00007f7753703000) => /usr/lib/x86_64-linux-gnu/ (0x00007f77534e3000) => /usr/lib/x86_64-linux-gnu/ (0x00007f77532d6000) => /usr/lib/x86_64-linux-gnu/ (0x00007f7753018000) => /usr/lib/x86_64-linux-gnu/ (0x00007f7752dcd000) => /usr/lib/x86_64-linux-gnu/ (0x00007f7752b35000) => /usr/lib/x86_64-linux-gnu/ (0x00007f77528ff000) => /usr/lib/x86_64-linux-gnu/ (0x00007f77526ad000) => /usr/lib/x86_64-linux-gnu/ (0x00007f77524a9000) => /lib/x86_64-linux-gnu/ (0x00007f77521b3000) => /lib/x86_64-linux-gnu/ (0x00007f7751f2e000) => /lib/x86_64-linux-gnu/ (0x00007f7751b8f000)
/lib64/ (0x00007f7757dba000) => /usr/lib/x86_64-linux-gnu/ (0x00007f7751973000) => /usr/lib/x86_64-linux-gnu/ (0x00007f775176a000) => /usr/lib/x86_64-linux-gnu/ (0x00007f7751550000) => /usr/lib/x86_64-linux-gnu/ (0x00007f775134a000) => /lib/x86_64-linux-gnu/ (0x00007f7751131000) => /usr/lib/x86_64-linux-gnu/ (0x00007f7750def000) => /usr/lib/x86_64-linux-gnu/ (0x00007f7750beb000) => /usr/lib/x86_64-linux-gnu/ (0x00007f77509db000) => /usr/lib/x86_64-linux-gnu/ (0x00007f77507d2000) => /usr/lib/x86_64-linux-gnu/ (0x00007f77505ce000) => /usr/lib/x86_64-linux-gnu/ (0x00007f77503cb000) => /usr/lib/x86_64-linux-gnu/ (0x00007f7750156000) => /lib/x86_64-linux-gnu/ (0x00007f774ff2f000) => /usr/lib/x86_64-linux-gnu/ (0x00007f774fd2c000) => /usr/lib/x86_64-linux-gnu/ (0x00007f774fb22000) => /lib/x86_64-linux-gnu/ (0x00007f774f8f8000) => /usr/lib/x86_64-linux-gnu/ (0x00007f774f6ef000) => /lib/x86_64-linux-gnu/ (0x00007f774f4b3000) => /usr/lib/x86_64-linux-gnu/ (0x00007f774f2b0000) => /usr/lib/x86_64-linux-gnu/ (0x00007f774f0a9000) => /lib/x86_64-linux-gnu/ (0x00007f774eea4000) => /lib/x86_64-linux-gnu/ (0x00007f774ec86000) => /lib/x86_64-linux-gnu/ (0x00007f774ea6a000)

Everything seems to be in order, but i am obviously missing something. I keep getting a "Missing Plug-In" message in Chrome and a blank page in Firefox. Firebug inspect confirms that there is no embed in the DOM. Have also checked with Youtube and Metacafe but no luck.

Tried 'sudo apt-get install flashplugin-installer' but it didn't work as well (probably since i am on 64bit) with :

Setting up flashplugin-installer ( ...
nspluginwrapper: no appropriate viewer found for /usr/lib/flashplugin-installer /
dpkg: error processing flashplugin-installer (--configure):
subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)
share|improve this question

I had the exact same problem a couple of days ago. I solved it by deleting from /usr/lib/mozilla/plugins and recopying it from the folder where I had extracted it from the download. I have no idea why this worked, but it did.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.