Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Was working fine before i played around with NVIDIA drivers and ended up with this problem. I tried running it through the terminal and i see these messages:

subsharm@subsharm-ThinkPad-T61:~$ supertuxkart
Irrlicht Engine version 1.7.2
Linux 3.0.0-15-generic #25-Ubuntu SMP Mon Jan 2 17:44:42 UTC 2012 x86_64
[FileManager] Data files will be fetched from: '/usr/share/games/supertuxkart/'
[IrrDriver] Creating NULL device
Irrlicht Engine version 1.7.2
Linux 3.0.0-15-generic #25-Ubuntu SMP Mon Jan 2 17:44:42 UTC 2012 x86_64
[IrrDriver] Trying OpenGL rendering.
[IrrDriver] Tring to create device with 32 bits
Xlib:  extension "GLX" missing on display ":0.0".
[IrrDriver Temp Logger] Level 1: No GLX support available. OpenGL driver will not work.
[IrrDriver Temp Logger] Level 2: Fatal error, could not get visual.
Segmentation fault


subsharm@subsharm-ThinkPad-T61:~$ sudo Xorg -configure
[sudo] password for subsharm: 
Fatal server error: Server is already active for display 0 
If this server is no longer running, remove /tmp/.X0-lock and start again.
share|improve this question
    
subsharm@subsharm-ThinkPad-T61:~$ sudo Xorg -configure [sudo] password for subsharm: Fatal server error: Server is already active for display 0 If this server is no longer running, remove /tmp/.X0-lock and start again. –  subeh.sharma Jan 23 '12 at 13:03
    
Just to clear any doubt, Currently i'm NOT running NVIDIA but the problem was seen even when NVIDIA was installed. –  subeh.sharma Jan 23 '12 at 13:16
1  
in a similar manner as I have tried to edit in your question - please re-edit your question with any clarifications - stuff in comments may be overlooked. –  fossfreedom Jan 23 '12 at 13:40
    
What driver did you tried? Did any of the two answers help to find a solution? –  qbi Mar 30 '12 at 23:09

2 Answers 2

You'll most likely need to use the proprietary Nvidia driver for SuperTuxKart to run properly. You may get it to start with the nouveau driver, but it will most certainly not function well.

share|improve this answer
    
it was working fine before i installed NVIDIA driver. Even after installing it, it didn't start. –  subeh.sharma Jan 23 '12 at 18:47

Try another version of the driver. Preferably use the distro's mechanism for installing non-free drivers, but if all else fails, try to download the latest driver from the NVIDIA website and install it.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.