Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Possible Duplicate:
Why are Flash applications so sluggish?

I am wondering, why is the HD video playback under Linux so bad? I mean, HD videos are laggy . I've tested many distos, on multiple PCs, but compared to Windows, the HD playback is always bad. Laggy all the time, and the online video playback? It's much worse. I tried both nvidia and amd video cards, the latest official drivers, even the open source drivers, but the HD playback performance is......

AMD E-300 with Radeon HD6310 (384 MB of RAM) Graphics, 4GB DDR3. The GPU is integrated, but I can run HD content on Windows without a problem, both locally and online, with flash player. I've tried many distros. Ubuntu, Xubuntu, Lubuntu, Linux Mint, Arch Linux, ArchBang, Fedora, SuSE. They all have the same problem, laggy flash playback, even at 480p!

I really want to stick with Linux, but I can't because of this fact. Do you have any tips? Is there a secret that I don't know? Just tell me please.

share|improve this question

marked as duplicate by Jorge Castro, Bruno Pereira, htorque, Takkat, Marco Ceppi Jan 26 '12 at 2:41

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

2  
I have not a single problem watching H10P video's with SMPlayer and/or VLC on a system that has an Radeon HD6650. See caesiums like and please answer the "Can you confirm hardware assisted decoding is actually being used at all?" question ;) –  Rinzwind Jan 23 '12 at 10:55
    
Hello. Rinzwind, the problem I have is not just locally; Like I said, HD playback with flash-player is much worse. –  user43207 Jan 23 '12 at 11:44

1 Answer 1

without having your distro etc and hardware info its hard to help with this. i have a nvidia card running ubuntu 12.04 and the latest Gnome-shell 3.3.4 and HD playback with VLC Mplayer is really smoth. have you tried a newer kernel and the x-org-edgers ppa?

share|improve this answer
    
AMD E-300 with Radeon HD6310 (384 MB of RAM) Graphics, 4GB DDR3. The GPU is integrated, but I can run HD content on Windows without a problem, both locally and online, with flash player. I've tried many distros. Ubuntu, Xubuntu, Lubuntu, Linux Mint, Arch Linux, ArchBang, Fedora, SuSE. They all have the same problem, laggy flash playback, even at 480p! –  user43207 Jan 23 '12 at 14:59
    
what do you have installed at the moment? Ubuntu? if so try this help.ubuntu.com/community/RadeonDriver –  bmbaker Jan 25 '12 at 22:27
    
just saw this on the ubuntu forums ubuntuforums.org/showthread.php?t=1915488 –  bmbaker Jan 26 '12 at 16:30

Not the answer you're looking for? Browse other questions tagged or ask your own question.