Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've always had this problems with skype and pulseaudio on ubuntu. Whenever i start up skype, i have to call someone, then hang up 4-5 times, before the other person can hear my voice.

When i, or the other person hang up, skype tends to lock up. I can't kill it with "killall skype" or a logout, so i have to restart my computer.

Have anyone else encountered this problem, and if so solved this? I'm using 10.10 btw.

share|improve this question
    
I would take a look at the bug list for 10.10 –  myusuf3 Oct 27 '10 at 18:43
    
I'm having the same issues with Ubuntu 10.10. I've got a quad core AMD, 4 GB of RAM, an NVidia 8300 graphics card, and am running 64 bit Ubuntu 10.10. Skype, which is my primary communication tool, has been locking up repeatedly. Removing the .Skype folder to see if it was something in my preferences made no difference. Going to the latest NVidia drivers didn't help. I'm getting frustrated enough that if I don't soon come up with a solution it'll be back to Ubuntu 10.4 for me. –  DaveB Oct 31 '10 at 21:05
    
Are you using the Beta? Is your Microphone input on a high volume? –  JasonO Nov 1 '10 at 0:16
    
I too have this problem. I am running a quad core AMD, 4 gb ram, Gtx260 and ubuntu 64 Bit 10.10. –  Sixthlaw Nov 1 '10 at 12:00
1  
killall -9 skype should terminate skype no matter what. –  LasseValentini Nov 8 '10 at 4:03
add comment

6 Answers 6

This may be unrelated, but i had all sorts of problems with ubuntu skype, until i went into skype configuration an unchecked, allow skype to manage sound settings.

share|improve this answer
1  
Actually this is the most common culprit. –  Daniel T Chen Nov 24 '10 at 14:50
add comment

I encountered this problem. It happen less time if I install skype using the Canonical partner repository Software Tab.

Else, to kill skype, you can go to system => Administration => System Monitor, and then you right click on the Skype process, and you kill it. It seems to be more powerfull than killall. It works for me.

share|improve this answer
add comment

This makes no sense, but I fixed this for myself but uninstalling a gmail checker. No kidding. I don't know if it was messing up pulse when it alerted me, but now both Skype and Rhythmbox work fine.

share|improve this answer
add comment

Your microphone volume could be too "high". Open "Sound Preferences" and try reducing it in the "Input" tab. Test it with the Sound Recorder application.

share|improve this answer
add comment

I had a similar problem sometime ago and I found the solution in this RH bug (comment 27).

Commenting the line load-module module-suspend-on-idle out in the /etc/pulse/default.pa file solved my latency problem.

share|improve this answer
add comment

For me launching Skype from the command line like this fixed it:

PULSE_SERVER=127.0.0.1 skype
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.