Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When installing a standard Ubuntu 10.04 system on my system, I have to use i915.modeset=0 xforcevesa when beginning the installation. I tried doing the same for a command line installation so I could have a base system and install lxde later, it doesn't work, i.e. if I don't use i915.modeset=0 xforcevesa, after booting, it just shows a blank screen. I get the same with a command line system plus lxde, i.e. a blank screen.

So my question is, where do I have to enter i915.modeset=0 xforcevesa after installing a command line install plus lxde?

share|improve this question

2 Answers 2

up vote 2 down vote accepted
+100

If you are doing a minimal install, you will need to install the X packages yourself prior to installing the desktop of your choice.

Thus, the key packages are xorg, xserver-xorg-core together with the video driver of your choice.

If you are just testing, my suggestion would be to install xserver-xorg-input-all for all the possible input devices together with xserver-xorg-video-all for all the open-source video-drivers.

Install these packages first, together with the GRUB entries quiet i915.modeset=0 xforcevesa to allow the GUI to display correctly.

share|improve this answer
    
I would prefer to install only install the required stuff only. How would I figure out which input device I need and which video driver I need? –  oshirowanen Feb 1 '12 at 19:13
    
... try installing all the stuff first to confirm that it is a driver issue first. If you install both input-all and video-all together with i915.modeset=0 and xforcevesa and you still get a black screen then we are looking for another solution. –  fossfreedom Feb 1 '12 at 19:20
    
Done, and I have discovered that i915.modeset=1 is what I need, i915.modeset=0 gives a blank screen and xforcevesa also works, but without any desktop effects. Tested this using the standard ubuntu live cd. After which I installed a base install and edited the grub file by adding i915.modeset=1 and i can get into slim and lxde. I will start a new question about the input-all and video-all. Thanks for the help. –  oshirowanen Feb 2 '12 at 10:41
1  
ok - its definitely the intel driver (xserver-xorg-video-intel) you need to install together with xorg and xserver-xorg-core. All the possible xserver-xorg-video stuff you could individually install is linked here: packages.ubuntu.com/… –  fossfreedom Feb 2 '12 at 10:50

Using any editor, open /etc/default/grub

# Graphical 
gksu gedit /etc/default/grub

# Command line
sudo -e /etc/default/grub

In your case, you may need to boot to recovery mode.

Look for the line

GRUB_CMDLINE_LINUX_DEFAULT=”quiet splash”

and add in those options

GRUB_CMDLINE_LINUX_DEFAULT=”quiet i915.modeset=0 xforcevesa console=tty1”

I personally would remove the splash, up to you.

Then update grub

sudo update-grub

I think you are affected by this bug : https://bugs.launchpad.net/ubuntu/+source/linux/+bug/914311

share|improve this answer
    
I'm still getting a blank screen. –  oshirowanen Jan 22 '12 at 20:59
    
Have you looked at something like: ubuntu-tutorials.com/2010/05/06/… ? –  arochester Jan 30 '12 at 10:54
    
I updated my answer, try adding console=tty1 as well, see the bug report I referenced. –  bodhi.zazen Jan 30 '12 at 13:19

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.