Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am using Google Chrome. I am facing problem in using Hindi News. which shows bullets instead of proper hindi text. but this same thing is not happening with Firefox it shows Hindi font .

when i use https://wiki.ubuntu.com/Fonts this in Firefox

Fonts In firefox

Font in Firefox

Fonts in Chrome

Font in Chrome

I used this site for solving this problem its tell me to modify .fonts.conf file I'm currently working on font settings in XML (.fonts.conf). I noticed that after installing msttcorefonts things don't look quite as good in Firefox anymore. Most web pages request Arial which doesn't get hinted and anti-aliased too nicely, especially on LCD screens. I personally prefer the "sharp" non-anti-aliased look. i hate the new look which comes from this conf.

I'm using Ubuntu 11.10 32bit . the Font i am using in this version of Ubuntu are the latest . or i have to update my fonts . is there any new font look in Ubuntu

share|improve this question
add comment

2 Answers 2

up vote 4 down vote accepted
+50

The Hindi font rendering problem in Chrome is already well-documented. There has been a bug report filed against this problem.

A workaround has been suggested in the bug report, but I consider it too drastic as it involves deleting a couple of fonts. Instead, we can achieve the same effect by renaming those fonts.

Enter these commands in a terminal:

sudo mv /usr/share/fonts/truetype/freefont/FreeSerif.ttf /usr/share/fonts/truetype/freefont/FreeSerif.ttf.backup
sudo mv /usr/share/fonts/truetype/freefont/FreeSans.ttf /usr/share/fonts/truetype/freefont/FreeSans.ttf.backup

The Google Chrome page after the above modification:

enter image description here

share|improve this answer
1  
Rather than delete the fonts, I first just prefixed them with "xxx" to get xxxFreeSerif.ttf and xxxFreeSans.ttf. That didn't work. Still got the empty boxes. So I copied them to my desktop (in case I ever need them) and then deleted them from the folder. That worked perfectly. –  user25656 Jan 29 '12 at 7:11
    
Thanks. Instead of deleting the fonts, I have recommended renaming it. –  jokerdino Jan 29 '12 at 9:11
add comment

My machine Hindi fonts were sometimes overlapping each other in Chrome browser and this was mostly happening in Facebook site. I changed my font to ARIAL UNICODE MS in Chrome's setting and the issue was resolved.

Hope it helps somebody with similar issue.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.