Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've had a problem with my system time, when I execute the following:
date && touch test && stat test

I get this result:

Sun Jan 22 17:52:07 MSK 2012
File: test
Size: 0 Blocks: 0 IO Block: 4096 regular empty file
Device: 1dh/29d Inode: 5543372 Links: 1
Access: (0644/-rw-r--r--) Uid: ( 0/ root) Gid: ( 0/ root)
Access: 2012-01-22 17:19:39.000000000 +0400
Modify: 2012-01-22 17:19:39.000000000 +0400
Change: 2012-01-22 17:19:39.000000000 +0400

This causes my imap server to give me an error upon login, namely
* BYE Clock skew detected. Check the clock on the file server

I tried to solve this using ntpdate and ntpd daemon, but though neither give me an error, the situation does not change. I tried ubuntu forums but nobody seems to know what to do. I would appreciate any help I could get.

share|improve this question
add comment

1 Answer 1

There is only one explanation why the time reported by date and the timestamp on a touched file would differ: the file you are touching is located on and NFS server and the server's time doesn't match the client's.

Check the time on the NFS server.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.