Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

On my new computer a 64 bits - I have a 64 bits Ubuntu 11.10 installed. Adding network printer with settings for a generic MG8100 printer:

Location: host-ip Device URI: lpd://host-ip/LPT5 model: Canon PIXMA MG8100 - CUPS+Gutenprint v5.2.7 Simplified

When I tried to make a test print this happen:

  1. Ubuntu send a print to the printer
  2. The printer shows on the display that it is working
  3. Ubuntu acknowledge with pop-up messages that print job was completed
  4. The printer stop working on the display and nothing happens, no print is produced

There are no errors as far as I can see it.

Do anybody knows what to do, or what is wrong?

Remarks On an old computer I have the Ubuntu 11.10 32 bits installed and the same printer connected with "Device URI: cnijet:/88-87-17-08-64-56" and that works fine on this computer. I tried to used that instead of the lpd setting on the new computer but then I got a cups client error.

I hope some body can help me with this.

share|improve this question
Have you tried the 8100series printer driver from this PPA: – fossfreedom Jan 22 '12 at 16:43
I found a solution as mention under answer but any way thank you for your comment I was looking at your link too. – Yngve Jan 24 '12 at 18:52
up vote 1 down vote accepted

I now succeeded in connecting the printer with correct driver by downloading the driver from canon home page From there I selected the driver for PIXMA MG8150 and downloaded the file *MG8100series-printer_driver.tar*.

I extracted the folder cnijfilter-mg8100series-3.40-1-deb. In the folder I run the script and follow the instructions from there and now it works.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.