Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

LibreCAD worked perfectly for me until I ran the update manager 1/12/1012. Since then it closes when ever I try to save or open a drawing (DXF.) I read that I should install the synaptic package manager so I did, and it won't open at all. I see the screen for a fraction of a second and then it's closed.

Other programs with issues are Konversation immediately closes if I select settings from the menu, and Skype closes immediately after logging in. If I enter the wrong password, it tells me it's the wrong password, but if I type in the correct password it closes as soon as it logs in. I'm a newbie, so I haven't been poking around, changing ownership or anything like that. I tried starting the programs from terminal and I get the following or similar messages:

Requesting child objects for an interface that is a virtual child itself. 
QSpiAdaptor::getChild INVALID CHILD:  QWidget(0x8ca7d50, name = "qt_scrollarea_viewport") 1 
ASSERT: "interface->childCount() == children.count()" in file adaptor.cpp, line 200
Aborted

I use 11.10 32bit on a HP Pavillion dv6000 2gb

share|improve this question

closed as off topic by jrg May 17 '12 at 19:02

Questions on Ask Ubuntu are expected to relate to Ubuntu within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

    
This question should instead be filed as a bug report, and as such is off-topic, thanks! Instructions on filing a bug report are here. –  coversnail May 17 '12 at 18:00

2 Answers 2

You should file a bug for the application in question. It sounds a little strange that you would get that exact message for all different kinds of applications. My guess is that you provided that as an example for one particular application, but forgot to mention which it was. Skype obviously cannot be fixed, but for other applications, you should file a bug on Launchpad.net. Provide that kind of information,

The easiest way to do it, is to open a terminal and run ubuntu-bug programname, like ubuntu-bug gcalctool. That will collect information about versions, and other relevant information and send it to the right place on Launchpad. This makes it much easier for developers to identify the issue so they can solve the problem.

share|improve this answer
    
Thanks. Filed bug reports. Hopefully some of this will get resolved. I'm losing ground. :) –  Terry Jan 23 '12 at 4:29

Try disabling QT accessibility and launching from the command line:

export QT_ACCESSIBILITY=0 && librecad

(found by googling "Requesting child objects for an interface that is a virtual child itself." --- it's an issue that affected some people when they upgraded to 11.10)

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.