Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm a Linux newbie. I'm doing a project that uses the gosmore routing engine. In one of my email to the developer about a certain problem, he replied to me that to solve the problem:

"I think you will have to move gosmore directory to a home directory and give the webserver read and execute rights. On my Ubuntu installation this is the /home/lambertus/gosmore and my webpages run in /home/lambertus/public_html/yours."

I did move the needed files to my home directory, and CHMOD it using this command:

chmod -R 755 gosmore/

The thing is, when I "ls -l" for the gosmore directory, it displays that I had had already set the permission correctly (drwxr-xr-x...). But when I check Permissions in the gosmore directory (right-click > Properties), the permissions are still not set. Because of these, my gosmore installation doesn't still work. What can I do to truly set the permissions that I need for the directories? Thanks in advance! :D

share|improve this question
2  
The only true way is that of the console. I mean, chmod and ls are likely right not nautilus (the right-click thing). If ls says that the permission are set, the permissions are set. –  Javier Rivera Oct 27 '10 at 10:18
    
@Javier: I disagree, Nautilus will show the same as ls (if it didn't, there would be 1000s of bug reports about that). –  JanC Oct 27 '10 at 16:53
    
@jalbautista: where (on what) did you right-click to check permissions in "Properties"? –  JanC Oct 27 '10 at 17:02
    
Also check to see if your folder is enabled if your not logged in. I have seen people's home directories get unmounted when they log off which could result in the same issue, that your seeing. –  myusuf3 Oct 27 '10 at 18:46
    
@JanC: on the file/directory I am checking. –  jalbautista Nov 2 '10 at 8:09

1 Answer 1

up vote 2 down vote accepted

Make sure you're looking at the same directory. Nautilus (the GUI) and ls (in the terminal) will show the same permissions. Where did you end up putting the gosmer directory? Usually this needs to be /home/USER/public_html/gosmer for the webserver to see it as http://localhost/~USER/gosmer/. To enable public_html, use sudo a2enmod user_dir.

Finally, is your webserver configured to run the language that gosmer uses? For example, PHP would need libapache2-mod-php installed, and if gosmer uses CGI, you'd need to enable the CGI module (sudo a2enmod cgi) and allow it (add ExecCGI to the Options directive for your virtual host in the Apache configurations. For example:

<Directory /somewhere>
  AllowOverride All
  Options MultiViews Indexes SymLinksIfOwnerMatch IncludesNoExec ExecCGI
  IndexOptions NameWidth=*
<Directory>

This may need to be done in /etc/apache2/mods-available/userdir.conf if you're using public_html as the target.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.