Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a Ubuntu 11.10 server setup with rackspace. Pretty basic setup LAMP, vsftp.

Create a new user for vsftp that can create files on the server perfectly fine.

But the files seem to be -rw------- when this user creates them, I'd like to see more of a -rw-r--r-- so that the files (.php files) can be served by Apache.

Where do I change this behaviour?

share|improve this question
up vote 1 down vote accepted

You need to set the 'local_umask' option in vsftpd.conf (its default value is '077' IIRC, which you might want to change to '033' or '022').

share|improve this answer
    
Thanks, nailed it! – nizzle Jan 22 '12 at 11:31

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.