Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

cheese records at painful fps. video recording is really slow in cheese almost unusable. How can I increase the fps for cheese.

I have HCL laptop with built in 1.3 MP camera 2.47 GHz i3 processor with 2 GB RAM. running maverick 32 bit.

I installed camorama from software centre which has fine video (fps), but I can't seem to use it due to some error. So I doubt there is something to be tweaked with cheese itself.

share|improve this question
    
Please could you edit your question to provide us with some more information about your hardware, in particular the model of your webcam? –  8128 Oct 27 '10 at 8:01
    
This question has information on how to find the information you need to update your question: askubuntu.com/questions/14008/… –  Jorge Castro Nov 28 '10 at 1:20

5 Answers 5

up vote 6 down vote accepted

There is NO option to edit fps in cheese. Cheese just streams direct video input from your webcam.

You mention slow fps during recording, but I'm assuming that the video displayed in cheese even when not recording has the same slow fps, right? In effect, the fps you see before recording is what you are recording?

If so, I imagine you are recording in your room? which means low lighting.

  • try taking the laptop outside in bright sunlight and test if the fps improves or not.

If fps does improve outside, it means that webcam driver is running with an auto-exposure setting ON. (That means the fps depends directly on the webcam exposure. More light more fps. Less light less fps.)

Some webcam drivers might have an option to turn this setting off.

To check : Install the v4l2ucp program. Once installed, you can start the program from the menu item System > Preferences > Video4Linux Control Panel . Check if you have the options for Automatic Gain and Exposure (a checkbox) , Exposure , Gain. If you have the options, then you can turn it off and adjust the options as suitable.


If you do not have the options, it means your webcam driver does not yet support the auto-exposure options.

If the webcam has options to toggle Auto-Exposure when you boot into Windows, then you're in luck. The option can be included in Linux kernel for your webcam.

Check if there is an existing bug requesting the feature: Search in Product: v4l-dvb

If not, File a bug in the kernel. Product: v4l-dvb , Select Component: webcam

Bug is an enhancement feature request and should include following info:

 lspci -vvnn
 lsusb
 dmesg
 uname -a
share|improve this answer
    
You were right about the fps being fine in the sunlight, followed the steps and now it works great. Thanks so much :) –  Gaurav Butola Nov 28 '10 at 13:25

go to edit->preferences and change the resolution to 640x480 and it'll be fine,you can take photos with 1280x1024 and videos with 640x480...good luck

share|improve this answer
    
I didn't mention about clicking pics but that's also the same. Its with really low fps, I have to stay still for 2 secs to stabilize the image and then press on take a photo. Its really unusable like this. in camaroma its fine, but i cant use that. –  Gaurav Butola Oct 27 '10 at 14:22
    
ohh well i have the same problem actually i thought that was the limit of a 1.3MP webcam –  Px Mohamed Oct 27 '10 at 14:29
    
I am sure the problem is cheese otherwise other programs would also have acted the same, which is not the case here. And 1.3mp is a decent camera to take pics and take videos. –  Gaurav Butola Oct 27 '10 at 14:34

I had a similar problem,I have a VGA webcam and cheese recorded very slow and jerky @640x480 resolution and 29fps. I got better results at 320x240 29fps however.

I searched for an alternative and then switched to guvcview (GTK UVC Viewer). It offers a lot of options for fine tuning all the webcam video recording. Now I can record videos even at 640x480 and 30fps.

PS: I don't remember how I got this installed. I forgot the repo etc. Sorry :p

share|improve this answer
    
I have guvcview already installed and its way better than cheese. thanks for the suggestion. –  Gaurav Butola Feb 23 '11 at 8:30
    
For reference, the PPA is launchpad.net/~pj-assis/+archive/ppa –  Zecc Apr 18 '12 at 16:25

Something from the Cheese FAQ:

I'm getting a really slow response with the video, the video is sluggish and everything looks quite slow, like as the video lags, what could i do?

You may have set "ximagesink" (X Window System (No Xv)) as video-output. This means, that your cpu is doing all the work. Change it to "xvimagesink" (X Window System (X11/XShm/Xv)) in order to let your graphics card do the work.

Where can I set those things mentioned in the answer above?

Just execute gstreamer-properties

So in summary: press Alt+F2, enter gstreamer-properties, change to the video tab, and play with the Default Output: Plugin option.

share|improve this answer
    
It was set to autodetect, I changed it to X Window System (X11/XShm/Xv) but it didn't help. –  Gaurav Butola Oct 27 '10 at 9:49

I am actually having the same problem. I suspect it may be related to this bug: https://bugs.launchpad.net/ubuntu/+source/cheese/+bug/332381

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.