Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

i'm using ubuntu 11.4 oneiric ocelot and tried to set up the Davical Server. I have installed it and added the users davical_app and davical_dba. A tutorial on http://wiki.davical.org/w/Ubuntu_Maverick told me to say no to all three questions. Then it said to add the following lines to /etc/postgresql/main/9.1/pg_hba.conf:

local   davical_app     trust
local   davical_dba     trust

I tried to restart the postgresql server as the manual told me by the following init script:

/etc/init.d/postgresql restart

but this failed. The command told me that it couldn't load the pg_hba files because of line 77 and 78: the ones I've added. Then I restarted my computer because I thought then the postgresql server must restart too. I tried to run the shell script in

su postgres -c /usr/share/davical/dba/create-database.sh

anyway, but it said that it couldn't find the postgresqlserver.

On http://mergy.org/2011/11/fixing-davical-and-postgresql-on-ubuntu-11-10/ I found a tutorial to fix davical and postgresql 9.1 but that didn't help. What can I do to get it run on my Ubuntu system?

share|improve this question
    
Is this still happening summerbrain or did you manage to solve it? –  Luis Apr 6 '12 at 19:14

1 Answer 1

The issue relies on the pgsql listening on a unix socket located at /tmp/ while the davical script expects the unix socket to be in /var/run/postgresql/

I don't know how to change davical to look at the specified dir, but you can change the former in /etc/postgres/version/postgresql.conf, line unix_dir.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.