Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

How does one get the frontend to communicate with the frontend? I have tried the default 127.0.0.1 on both front end and back end with default values for username and password, to no avail. I've also tried the username and password that I had set on install, still no luck.

What is the actual procedure?

share|improve this question
    
in the backend config, for the mysql/database username and password, is the username set to root or is it set to something else? if it's not root, then set to 'root' –  duffydack Jan 21 '12 at 19:55
    
Off topic I know, and take this comment for what it is (good natured advice) but have you tried XBMC? I only suggest this as I had an unacceptable amount of issues with MythTV (connecting the front end to the back end mainly) and I only wish someone mentioned XBMC to me earlier because once I switched to XBMC (help.ubuntu.com/community/XBMC), I've had not one single issue. –  Switchkick Jan 22 '12 at 2:20
add comment

1 Answer 1

You should only be using 127.0.0.1 if the frontend and backend are on the same machine. If they are on the same machine, then it should already know where the backend is. If that is failing it means the backend probably isn't running, which is most often caused by not having run mythtv-setup yet.

If they are on different machines, then you need to go to the backend and find the username/password combination. This will be located in the /etc/mythtv/mysql.txt file. (username should be mythtv, password will be something that was generated). On the backend, you will also need to run the Mythbuntu Control Centre and activate the mythtv service (allowing remote machines to connect to this backend). Again you will need to run mythtv-setup and go though the steps, make sure you use the actual machine IP though and not the loopback address.

You can verify if the backend is running or not with 'sudo service mythtv-backend status'

share|improve this answer
    
this helped me a ton! I tried ssh from the frontend to the backend and I got connection refused. I'm hoping when i enable mythtv service it will work. Also, its not the root user password i need to enter for mysql correct? I have to check the text file when i get home. –  Drewdin Mar 8 '12 at 15:13
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.